User Activity

Trying to install the EOS Utility for my Canon 5D Markii (I know I should have done it before now). Canon is showing there isn't a compatible version. Is that correct?  I would like to live view for remote shooting. If this is correct, is there a wor...