cancel
Showing results for 
Search instead for 
Did you mean: 

580 EX II won't fire.

matonanjin
Contributor

But everything else works.  It just won't fire with the test "Pilot" button or attached to the hot shoe.  

The back story is that I just bought this off eBay.  So yeah, I know, I got snookered.  But I have always used Metz 58AF's so, before accusing the seller or sending it in, I want to make sure that I am not missing something really obvious.

Is there a reset or reboot process?

And what makes me really confused is everything works EXCEPT a test flash.  Before attaching it I can zoom it, I can go into Custom Functions, I can change modes, put it in HSS/back curtain, everything.  If I attach it, it communicates completely with my camera (5DS R).  I can go to Speedlight menu on my camera and modify all items: ETTL, +-, zoom it from camera.  All functions available in the menu, I can change.

What am I missing?  

5 REPLIES 5

kvbarkley
VIP

It is unclear from your message, does the flash fire when you take an image?

If it does, it is probably the test button and you are probably OK, if it does not flash when commanded from the camera, it is probably the flash tube and needs to be repaired.

I'm sorry I was unclear.  There is no taking an image.  It does not flash.  It does not fire.  From my message, "It just won't fire with the test "Pilot" button or attached to the hot shoe."   (Bolding mine)

Looks like I'm sending it off to repair for a flash tube which, I'm guessing, is as much as what I paid for it.  

Thanks for replying.

"And what makes me really confused is everything works EXCEPT a test flash"

Looks like I'm sending it off to repair for a flash tube which, I'm guessing, is as much as what I paid for it.”

Why aren’t you dealing with eBay for return and refund?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

And John, that is exactly what I did. Shockingly, the seller took it back very willingly, even apologetically.

Announcements