Showing results for 
Show  only  | Search instead for 
Did you mean: 

pro-1000 stuck on processing please wait. Won't print.


My imageprograf pro-1000 hangs on the processing please wait screen forever and I cannot get it to print.  Any suggestions?  Thanks


Yes! So I talked to support yesterday evening and here is what I did that worked. I unplugged the printer from power. I unplugged the USB cable not just from my laptop but literally from the Canon Pro 1000. Then I pushed the power button 10 times. Then I plugged the power back in and turned the printer back on. Then I didn't just erase my drivers, I "reset printing system." And then I went to the home button on my printer. And just printed something directly from the printer -- I think anything would work. I can't quite remember but maybe it was print LAN settings? Anyway its suppose to engage the logic board while you are still unconnected to your Macbook. I want to say that I never air print. So I never had to unconnect this -- but you would need to do that at the beginning I think for this to work. Finally -- the printer printed out the settings and when that worked. We did a nozzle check - I think just as a per-caution -- it was fine. Then I reconnected my USB cord and printed! And it worked! The only weird thing is that the whole "processing" loop started in the beginning when I was replacing an ink cartridge with a new cartridge and after everything the printer is showing that my Black Matte is still completely empty? I double checked the ink and its literally still full but the printer is still saying its empty. But hey -- it's running again! I'm not sure what's going to happen...but if it stops again -- I'll update this post. The support person I got was really helpful. Let me know if any of this helps! I'm running a Macbook Pro 12.2. And using Photoshop. 

View solution in original post



Hi, skogie1!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. Windows or Mac OS, and which version thereof), which applications you're trying to print from, and how your printer is connected to your computer. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Thanks Danny.


I am connected to a Macbook pro, 2018, running Big Sur 11.3.  My laptop has 32gb ram and an i9 processor and a dedicated video card whith 4gb ram.  I am using Lightroom Classic and I am connected to the printer with a USB cable through a hub as my laptop only has ports for the Thunderbolt connections.


However, the issue I'm having seems separate from my hardware and software.  When I start the printer, it goes through the agitation process then it says "processing....please wait momentarily."  This happens whether I'm connnected to my computer or not.  I've left the printer for as long as 20 minutes and it doesn't not move past that screen.  Also, I cannot turn it off using the power button when it is in this state and I have to unplug it to shut it down.


Any suggestions?

Hi skogie1,


Because this issue is hardware related, it is recommended that you contact one of Canon's Technical Support Representatives via phone or chat. To contact a Technical Support Representative, please use the link below:





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


Hi Skogie,

Did you resolve this issue? I have had this exact same problem with my PRO-1000,  not once, but three times. I have had 2 full warranty replacements from canon. It's now happened again with my 3rd new printer, and I no longer have warranty. Printer is only a few months old. Canon tried to say I am the only one who has ever had his issue. Any update welcome!

No I never got it resolved.  I couldn't get anywhere with customer service and learned to live with it.  It's BS.  Sometimes it takes more than 20 minutes to get it unblocked.  I've tried everything.  Sorry I don't have a solution to share.  Let me know if you get one.  Thanks and good luck.

Thanks for the update. I’ll let you know if I get a solution. How do you actually unblock yours? If I leave mine churning over it just makes a noise and chucks all the ink in to the maintenance cartridge and I can never get it to actually work. So the machine is unusable. 

I've got exactly the same problem, this has only just started, it's ridiculous, this must be a canon software problem, surely they must have an answer to it

is your machine unusable like mine? Are you in the US? I’m in the U.K. when I tried to get my original machine fixed the engineer didn’t have a clue. 


I'm in the UK to, they must know about it, has this now started working again after using up to much ink going round in circles,

I uninstalled  the printer then updated the driver and at the moment it's working