cancel
Showing results for 
Search instead for 
Did you mean: 

Can someone tell me how to fix "cannot communicate w/ printer" error message on Canon PRINT app

deliciousmacro
Apprentice

The Canon PRINT app was working fine until i recently updated to version 2.2.0. Now after updating the app will not work on my iPhone 5. The app will work sometimes on my iPhone 6s. However the app says "cannont communicate with printer" very often. It seems random.

 

How do i fix this? And why does the app not work any more on iphone 5?

17 REPLIES 17

see the easy fix that I found in one of my posts 31/1/2018

asmit
Apprentice
Me too. Both phone and printer connected to our spectrum account but phone is not finding printer. I have a Pixma MG7520 and an i phone that's a few years old. It keeps telling me to set up the LAN line but I have done that numerous times. Frustrated.

Scott-e-o
Apprentice
iPhone will not communicate with printer.

thubleau
Contributor
I have the same problem.it is the app.i have to uninstall and then reinstall to get it to work once after that it fails again.Its not the printer.I have a pro 100 and a 7765 they both won't work

This is how I fixed it for the Canon Pixma MX922 for my two Macs.

 

I can scan with the PC interface and the control panel on the printer.  I had to enter my SSID and password manually as doing it with WPS did not work for my ATT router.

 

I was able to download necessary files for Macbook Pro 17" 2007 OS X El Capitan v 10.11 and Macbook Pro 15' 2017 OS X Sierra v 10.12.6.  Received same error as seen here "Cannot communicate with printer" error.

 

I received a DVD with printer software with the printer but it did not contain what I needed just a link that opened a web page when I chose my OS for each Macbook.  I bought an external optical drive for optical drive software since the 15" has no optical drive.  You don't need the DVD, you can go to the below site.

 

I went to Canon's site using link from the DVD https://www.usa.canon.com/internet/portal/us/home/support/details/printers/inkjet-multifunction/mx-s...

 

I think Register Product here is required.  Despite my registering it elsewhere this particular location seemed to make everything work wrt getting the right files and having them install without issue.

 

The site detected MACOS Sierra v10.12 (it also auto-detected correctly with my El Capitan Macbook Pro)

Click on Drivers & Downloads

Click Select on the three listed drivers

 

Select MX920 CUPS Printer Driver Ver 16.20.0.0

Download mcpd-mac-mx920-16_20_0_0-ea21_3.dmg 

 

Select MX920 Scanner Driver Ver.19.1.0b

Download msd_-mac-mx920-19_1_0a-ea11.dmg

 

Select Optional ICA Driver Ver.4.0.0.a-ea11.dm

Download misd-mac-ijscanner5-4_0_0-ea19_2.dmg

 

Double click on each file and install them according to instruction

Go to System Preferences - Printers & Scanners

Click the + and add Canon MX920 series  Bonjour Multifunction

Check Share this printer on the network 

Turn Printer Sharing on

Click Sharing Preferences add Users if needed

 

Your installation should have placed files you need in the Canon Utilities folder

In IJ Scan Utility folder double click Canon IJ Scan Utility this is the new MP Navigator Ex from what I can tell.

 

The Canon IJ Scan Utility interface will open 

Click to choose Product Name and change to Canon MX920 series Network (this got rid of the error unable to communicate) . If I left it as the default (Canon MX920 series I get the cannot communicate error)

You can now set your scanning preferences by double clicking Auto etc

Click OK on the message Scan by automatically selecting the settings......

 

The on-screen manual is less useful for settings info than the online manual.

 

 

see solution below

thubleau
Contributor

The solution is this.

Firstly I can say that Canon were no help and no one on the net could help me .

This is what i did.

Unfortunately you have to use a ethernet cable from the printer to your modem  or router.

Change from wireless to lan setting on printer .

You will probably end up with an address like 192.168.1.95 .if you can make this a static address

restart your modem or router

restart your smartphone 

Open the canon print app and search for printers and it should pop up straight away.

For some reason the wireless communication between the modem and the printer is flaky so use the lan setup and not the wireless.

denfren
Apprentice
I have a mx430 printer and the app on my android phone stopped communicating with it although the phone and printer were on the same wireless network. The problem was resolved when I shut down my vpn connection (cyberghost).
Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x