cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Pro4000s ink tubes creating vacuum

LaserActs
Apprentice

Good day Canon Community.

I have a Canon Pro4000s and recently had a hardware error EC21-2F51. In service mode printer works normally. On normal mode the error appears no matter how many times I restart the printer. Installed new ink and a new MC-30 cartridge less than a week ago. 4 days later the newly installed MC-30 cartridge was full and had to replace with new MC-30 again.

I gently cleaned the print head with distilled water, rubbing oil, lint free cloth etc, error has seems to clear trying to fill the print head. Now a new error EC3F-2F40 appears. I dismantled the printer and removed the purge unit and cleaned the 3x ink pads and flushed out the old ink etc.

Installed everything and printer continued to start up normally without any errors until filling the print head cycle... Filling print head with ink takes ages only to discover that all ink tubes are completely empty. (New ink installed)

Set machine to open ink valve setting and used a syringe to pull ink back into the tubes close to print head. Once I remove the syringe, the ink returns back to the ink cartridges in each ink tube. It seems that there is a vacuum somewhere that is causing the ink to return…

The closest Canon repair centre is about 180km away, Canon SA has got no parts available and has to order with 3 to 4 weeks estimated delivery… I still have a lot of print work to complete before next week Friday.

Please I need help to resolve this issue.

1 REPLY 1

ArthurJ
Product Expert
Product Expert

Hi,

it is recommended that you call our Enterprise & Desktop Solutions Divisions at 1-800-423-2366 Monday-Friday 9:00 am to 8:00 pm ET, excluding holidays.

We look forward to hearing from you. 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements