Showing results for 
Show  only  | Search instead for 
Did you mean: 

Suddenly I cannot scan with my TS5320 that worked fine for 2 years


I bought this all-in-one almost exactly two years ago and had it running without issue until now.

Mind you, in that time I replaced the 27" iMac I had with an M1 MacBook Pro running Monterey around the end of last year, and the switch did not impact anything - I could print and scan as needed.

However, now I find the scanner is not responding to the MacBook - this is whether I use Apple's Image Capture program (which always worked without issue) or Canon's own software.

Further, I am understanding others have had this issue. I typically download the OSX updates shortly after Apple pushes them out, since they make it migh on impossible to ignore ("undt you VILL do as we say - we care for you!") and can only surmise the issue has to do with a driver that Canon needs to update. Has anyone here been similarly afflicted?

Oh, so as not to bask Canon, so to speak, I also have to say that my Epson FastFoto 640 photo scanner, which has been working without issue for 4+ years, also cannot connect to the MacBook - and that is with a wired USB connection. Again, this leads me to believe it is Apple's fault - I am hoping osmeone might know of a fix.

TIA for any help