cancel
Showing results for 
Search instead for 
Did you mean: 

Pixma MG6821 not found on my computer (Mac OS X El Capitan 10.11.1); printer itself finds my network

runnergirl
Contributor

Just purchased the Pixma MG6821 printer and went through the installation.  The printer itself is connected to my guest LAN.  Unfortunately, my MacBook Air is not finding the MG6821.  I downloaded the correct driver (mac-mg6800-1_0-mcd.dmg) and opened it - CANON_IJ.  I think I sort of know what the problem might be, but I don't know how to resolve it.

 

When the setup first occurred, I saw the printer serial number, MAC address, and LAN name (not my guest LAN) come up, but then the installation did not complete.  On the printer itself, it did not find my home LAN -- just my guest LAN.  I finished the setup on the printer and put in the PW for the guest LAN.  All is happy on the printer itself.

 

When I go through the installation again on the laptop, it now doesn't find the printer, and I suspect it is somehow still looking on my other LAN instead of my guest LAN.  I would prefer the printer on the guest LAN in case I have friends who come over and want to use the printer (the WPA2 PW is "easier" to type in).  I also want to set up my Android smartphone to print, and it is connected on my guest LAN.

 

How do I fix this problem?  Is there a way to disassociate the printer on the computer from my home LAN and associate it to the guest LAN?  Or am I stuck changing the LAN to my home LAN on the printer itself?  

 

I am guessing this is the problem, but all suggestions and help are welcome.

 

I need to get this resolved since there is a time limit on returning the printer.  I have only 2 more weeks left (was not able to work on the setup last week because of Thanksgiving).  

 

Thanks, Lynne

6 REPLIES 6

runnergirl
Contributor

11/30/15 UPDATE:  I added my non-guest LAN on the printer but was unable to delete the guest LAN.  The printer still shows only the guest LAN on the small display.  I re-ran the driver installation multiple times on my laptop, and although the printer is now found, the installation fails.

 

The MP drivers get downloaded, and then I see 100% for installation immediately followed by

MP drivers could not be installed.  Installation failure.

 

It tells me to start over.  

 

Well, after 4 more times with the same thing, I am now trying to stand in the corner in a round room.  THIS FLAT DOESN'T WORK.

 

I will probably be returning this printer -- just not worth it.  I will continue to use my 10-year-old Epson Stylus Photo RX620.  I will start looking at Epson printers again.

 

This is PATHETIC -- the installation should be simple.  

 

I can't find anything on the Canon site or anywhere online on how to resolve this issue.

Hi, Lynne!

Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, contacting our US-based technical support team is the most efficient way to get these issues straightened out. They're standing by, ready to help 24/7 via Email at http://bit.ly/Canon-Support or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).

Thanks and have a great day!

Hi Danny,

 

I was on the phone with Aaron at customer support for over an hour this afternoon.  The good news is that we got the printer to work with my MacBook Air.  The "bad" news is that it works ONLY on my guest LAN and I now need to connect my laptop to my guest LAN instead of my "home" LAN.  But at least it works. Also on the down side, I had to leave for a prior appointment, and I will need to call back and finish the set up/installation - see below.

 

I was NOT able to use the "default" package for the download as recommended in the instructions.  Aaron sent me to another page on the usa.canon.com site where we individually downloaded and installed 2 of 3 drivers.  I have not yet tried to scan and I want to try printing a photo, too.  

 

I still have to install all this on my husband's MacBook Pro, so it will be a good test of all the notes I took.  

 

The page Aaron sent me to was nowhere to be found in all my searches.  I had to power off my router 3 times, too, before anything worked.

 

I plan on updating this forum post with the steps we followed when I know everything works.  If I am happy for the next week using this printer on both computers, then I'll probably keep it.  

 

Thanks, Lynne

My problem was resolved by Aaron as posted above.

 

These are the steps:

  • Go to canon.com/usa OR usa.canon.com (the 1st link takes you to usa.canon.com)
  • In the search field, enter MG6821 - this will bring you to the Downloads & Drivers page for this printer
  • When I got to this page, it detected my OS - Mac OS X El Capitan 10.11.1
  • FIRST download MG6800 series CUPS Printer Driver Ver 13.6.0.0 (OS X) - this is the Canon IJ Printer Driver
  • After the .dmg file is downloaded, click to open and install
  • SECOND download ICE Driver Ver. 4.1.2 (OS X) - this is a scanner driver for this printer
  • After the .dmg file is downloaded, click to open and install
  • ON THE PRINTER ITSELF, go to the screen and select LAN settings --> Wireless LAN setup --> Standard setup 
  • You will get Searching for wireless router
  • In my case, my guest LAN was found 
  • Select the LAN and follow the prompts to enter the password - after this, my printer was on my guest LAN
  • Back to your computer: System Preferences --> Printers and Scanners 
  • Click on the plus sign (+) to add the printer
  • Wait a bit -- the first MG6800 printer that comes up in the list is Multitask Bonjour - you do not want this one. Also, do not select the MG6800 that is listed under Nearby printers -- you won't get the correct one, which is Canon IJNetwork
  • The 2nd one that comes up in the list is the one you want - it says Canon IJNetwork
  • Select Canon IJNetwork to add it to your network - at this point, the printer, your computer, and your LAN should be coexisting in harmony with each other 
  • THIRD download IJ Scan Utility Verx. 2.1.6 (OS X) - this is optional, but I have already used it, and it works nicely for "easy" scans
  • After the .dmg file is downloaded, click to open and install
  • Do a test print and test scan

Some tips:

  • It apparently depends on the app for giving you the 2-sided print option, but so far, I have had that option EXCEPT in Adobe Reader for PDFs.
  • I set the default on the printer itself to do 2-sided printing and copying, but I guess the apps you are printing from can override it
  • If the doc you are printing is 100% text with no color in it at all, the printer uses the larger black cartridge; else, it uses the small one even when you select print in grayscale

 

Lynne

 

I forgot to add this:

 

Before Aaron and I got started, he guided me on clearing out my LAN settings to we could start fresh.

 

On the printer:

Setup ---> Device settings ---> Reset settings ---> LAN settings only

 

I don't recall some of the other problems, but I did have to turn off my router and unplug it 3 times to help with the reset for some reason.  

 

I was able to successfully install the printer on my husband's MacBook Pro (also on El Capitan) with no problems following the steps in my previous post.

Thank you so much for posting this!  I couldn't get mine to work and followed your instructions and it finally worked!!!! 🙂

Announcements