Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MG6320 "Cannot connect to the server" for Cloud Printing


My Canon Pixma MG6320 printer is offline and I can't get it to go back online. I do NOT have it hard-wired to a computer or the network. It is wireless for printing and connection to the network. 


I deleted my Google cloud print registration using the printer options and then tried to set it back up after powering down the printer and restarting. However, I always get an Error message on the printer when I try to complete the Google cloud print setup that says: "Cannot connect to the server. Please wait a while and try again." 


I have tried this multiple times with 2 different wireless routers. My router can definitely see the printer.


How do I fix this? This printer is basically useless to me and I've only had it for a year and barely used it. Any help would be much appreciated.


Thank you.



Hello jessewien!

Welcome to the Canon Forums and thanks for your post!

To have a better understanding of your issue, please let everyone know what operating system (Windows Vista/7/8 or Mac OS 10.X) you are using. That way, the community will be able to assist you with suggestions appropriate for your product.

Any other details you'd like to give will only help the Community better understand your issue!

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).


It doesn't matter what OS is used... This is an issue with the printer connecting to the Google cloud for printing wirelessly.


We had the same problem, "cannot connect to the server..." with our MG6220, after it had been cloud printing fine previously.  

We found on a Google forum that changing the DNS setting in the printer to a public DNS, solved the problem.  It worked!!!


Nothing else we tried previously solved the proglem

Thanks for the suggestion, but I don't see an option to do that. Can you provide any more info?  




Go into Setup -> Device Settings -> LAN settings -> Other Settings -> TCP/IP Settings -> IPv4 -> (click yes) -> DNS Server. You can then manually enter a public DNS, I used  (selecting 'auto' in DNS did not help us)


There is addional info on this Google blog - link below.   The google moderator for cloud print is very knowledgable.!msg/gcp-developers/pOz0nHCo65s/...

Thanks for the info. Unfortunately, changing to didn't work for me. I still get the error about not being able to connect to the server. Hopefully Canon does something to fix this soon.

Exact same problem for my MG5420. Combine this lack of functionality with the exsanguination from ink purchases,, and I'm moving on to a different product. Life is too short (and demanding).

Subsequent to working with DNS set to for a number of days, ours lost the connection again.  Same error message.  As a work around, I leave my Windows computer 'on' and it has the Canon Pixma connected to it via a traditional USB cable.  It is the  'classic' printer stetup and then shared with others in the household through Chrome printer management.  It now prints again from our chromebooks, but the Windows computer needs to be on.


It would be much better to be able to cloud print like before, and not need to have a Windows machine in the loop, but until Canon works it out with Google (evidiently some change on the Google end caused all of us Canon printer users to loose our cloud print capbilites), at least I can print again from a chromebook.


If you call Canon support, they will put you on a contact list to be notified when they have the cloud priint fix/solution.  Hopefully that will happen 🙂

"If you call Canon support, they will put you on a contact list to be notified when they have the cloud priint fix/solution.  Hopefully that will happen"


Don't hold your breath.

Canon LIVE! Canon LIVE!