Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA G7020 Prints from One Mac but Not the Other


I am setting up a new Pixma G7020 on a WiFi network.  I am able to print from a M1 Mac Mini using WiFi but my MacBook Pro 12.6.3 won't print on WiFi or a USB cable.  When I attempt to print a document on the MacBook Pro the print dialog popup defaults to a Brother laser. I am able to select the 7020 in the Printer field, however I am puzzled as I have have the 7020 set as the Default printer in System Preferences.  When I select the Canon G7000 series printer I see a black circle with an ! mark in it.  

I did try deleting the printer in System Preferences and adding it back.  There were two choices. One was Canon G7000 series Bonjour Multifunction and the other was Canon G7000 series Robert's Mini Bonjour Shared.  When I selected the Bonjour Multifunction I saw 2 new devices one was the printer and the other a Fax.  The printer entry had a green dot in front of Idle just as the Brother did. I then tried printing a document.  The printer icon showed up on the dock with Ready to Print - 1 page under a progress bar however nothing printed.  In System Preferences there was a yellow dot in front of Paused.

I then tried adding the Robert's Mini Bonjour Shared printer and the same entry appeared in the list of printers as the previous attempt.  I then tried to print a page.  Once again the Brother printer popped up even though the Canon was set as the default printer.  I selected the Canon G7000 .... printer and it had a diamond in front of it with perhaps a very small figure in it.  I pressed print and a strange icon showed up in the dock that was not an image of the G7020.  When I clicked on it the popup said the printer was ready to print.  

What am I doing wrong?




Just a follow up.  I also have a Brother printer on my network and the MacBook Pro will print on it just not the Canon. A contributor on the Apple Forum suggested deleting the printer in System Preferences and adding it with the Option key pressed.  That also did not work.

Canon LIVE! Canon LIVE!