Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mx920 Wireless printing problem


I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159


Going to add... you win Canon!  My printer is now parked in my formal dining room, corded old style to my computer in an adjacent room with a printing cable.  So much for making technological progress in the 21st century.


I did all the fixes mentioned.  


When I spoke with a Canon tech support guy, he asked me to print out my LAN settings.  My signal strength was 51%.  He said that's not high enough to establish a connection.  Asked me where my router was.  It is in the SAME ROOM!!!  I was looking at it!!  


I said my computer received the signal strength with no problems at all.  He said the printer's wireless receiver was very weak compared to a computer.


Hence, the printer can't get the wireless signal because it's not strong enough.  Geez, my LAST Canon wireless printer was strong enough.  What happened?  Did we farm out that particular part to China?  Seems like a pretty important part when making a "wireless" printer.


Same as everyone else here.  VERY disappointed Cannon customer!  Using Win 8.1, sometimes I've been able to print but most of the time not.  Pwr down pwr up not working here.  Funny thing is my android phone App 'Printer Share' (paid App but well worth the cost) prints just fine with the Cannon mx922......but not from my Lenovo IdeaPad.  Also, the few times the printer worked from laptop it took forever to print, the printer is busy 'shuffling' around internally forever before it prints. 


Already set all the settings suggested on here.  Another link suggested cleaning some plastic strip in the back of the printer seen thru the area where the ink cartridges are, but I don't see anything in there to clean.



Costco product, gonna look into a better product.


I had this same problem on my mac and was able to fix it with AOS computer servies help. I'll share with all of you how I fixed mine. Sorry to all Pc users this will only be how to do it on a mac but if you want to try it and see if it helps you then go right ahead. 1st off mostlikly you were using air print on the 1st day. This is the basic way to print and its not very good at all. you will need to download the drivers so that you computer can comunicat with the printer. Go to Right under the bar that says fetured products there should be 3 squares and the 1st one should say support and drivers click on that. After that it will look like you have come to a blank screen on the left side under where it says product type click on customer & home office. After you click on that where it says enter your model name you would enter "mx 922"(EVEN IF YOURS IS THE 920 THEY DONT HAVE THAT 922 WORKS JUST AS WELL) or whatever the name of your canon printer/product is. Then once you click that you will see a picture of your printer come up, under that you will want to scroll down under drivers & software keep scrolling down till you see recomended for you then after that you will see a list click on the 1st one drivers. Under that there will only be on file and you will click on that one (the file is called ICA Driver Ver. 3.1.0 (OS X 10.6/10.7/10.8/10.9)") Then you will have to check the box then download that file. After the file is downloaded you will want to go to you printer and figure out what the IP adress is. (sorry I dont know how to do that the computer guy did it for me) then after that you will want to go to system preferences on you computer doc. click on printers & scanners. down in the left corner you will see a plus click on that. Once the next page comes up go to the top where it says IP. click on that then enter the IP address under address. Then if you have gotten the IP address correct it will tell you so and let you add the printer. After this you should be able to print wirelessly. You will just need to select that printer and the name of it will be the IP address. thats how you do it. hope that was helpful enough to all of you having this problem.  Ill put images below if your more of a visual person and cant follow what was written above. 





















Although mmxciv claims he had the same problem as the rest of us, and solved it by downloading & installing Canon's driver onto his Mac, I doubt the problem he solved was the "lost wireless connection after printer inactivity" problem that plagues the rest of us.  I think his problem was that he had neglected to install the printer driver.


My printer is a Canon MG6320 and it has the "lost wireless connection after printer inactivity" problem. (Both printing and scanning fail.) Turning it off and on makes it work okay (if you ignore the wasted startup ink and wasted time) until the next time. 


Disabling the printer's Wireless LAN DRX setting didn't help.  My wifi router is assigning static IP addresses to the pc and the printer, so dynamic IP addressing isn't the problem either. (Other notes: The pc runs Windows Vista Home Premium/32 and has a wired connection to the wifi router, and both the pc and router are active all day and all night.)


Has anyone figured out how many hours of printer inactivity trigger the problem?  Is it always overnight inactivity that triggers it, or will enough inactive hours during the day also trigger it?

I may have solved the problem.  Two days ago I used Windows' Control Panel's "Programs and Features" to uninstall all Canon-related software, and then reinstalled the wireless printer.  Since then, no problems.


Assuming the problem has been solved, I suspect the problem is caused by Canon's software engineers' incompetence at letting the user switch the printer from a USB installation to a wireless installation.  If it's necessary to uninstall the USB installation software before re-installing the printer as a wireless printer, then the Canon documentation needs to mention it.


Perhaps I uninstalled more software than necessary.  There were about 8 different Canon items installed.  Uninstalling all of them lost my preferences and the printing presets I'd saved (during the months the printer had been connected via USB).  Perhaps it was only necessary to uninstall Canon's USB driver.


In my opinion, uninstalling the USB installation shouldn't be required.  The driver ought to be redesigned so it will detect the printer no matter how the printer is connected.


UPDATE (2014-08-28): Alas, the above procedure (uninstalling all Canon software and reinstalling the printer) did not solve the problem.  It just wasted more labor.

Go look at my post on page 6 "mmxciv"


Got a" Printer Not Responding"

Tried to turn on and off printer, sending message from a Dell, Worked for a month now get this message. How can a novic reset

Lucille, more details would help. Does the printer not work at all now? Is the problem intermittent? Do you get the "printer not responding" error message only after several hours of printer inactivity, or even after you turn the printer off and on?

When you look at the printer, does it appear to be on? Is its blue icon lit? (When lit, it indicates the printer's wireless radio is enabled.)

By the way, when you turn the printer off and on, try waiting about 10 seconds while it's off, before turning it back on. This delay might be necessary to allow the printer's power capacitors time to discharge so that all circuits in the printer are truly reset.

What do you mean by "sending message from a Dell?"

Your network router is probably set to automatically assign dynamic IP addresses to all wired and wireless devices, which means the printer's IP address may vary from time to time depending on the order in which the router assigns addresses. If the printer was installed in a way that causes the computer to expect the printer to always have a particular IP address, that might explain why it would stop working after working okay for a month. If that's the problem, it should be simple to fix, since the router should be able to be reconfigured to assign a particular address to the printer.

If the printer is only a month old it is still under warranty. Canon's free & toll-free tech support may be able to help.

Good luck.


In my experience, the issue would occur after a prolonged idle period.

I was able to still connect to the web interface and see that the signal level was low, reset the WLAN connection and that would make it respond again. This is a workaround, not a solution. It appears that the issue is in the power management engine in the printer. Moving the printer to a wired connection solved it for me. I have my WLAN and wired network bridged so that the printer is visible on either segment. Not ideal, but at least I can print. This issue is independent of any driver software.



I am having the same issue.  I have several computers, most run a form of linux and I cannot print from any of them.  I also cannot print from the Windows 7 computer or the ipad.  Windows is showing the printer as offline but it can see the printer.  We have also printed many times before with no issues.  We powered the printer off and on one time but will try that again.  Not happy. 

click here to view the gallery