cancel
Showing results for 
Search instead for 
Did you mean: 

MX882 printer won't connect either via wireless or cable

kob6
Apprentice

I am using a Canon MX882 printer on a Windows 7 machine. 

 

I set this printer up months ago and it was working fine. I connected via wifi. The printer quickly discovered my wirless network and the connection was fine. 

 

I recently had to install a new wireless router from Verizon. I can connect to the Internet, however, my printer doesn't display the network. It shows every wirless network in my apartment building but mine. Rebooting of PC and network router failed to resolve this problem. 

 

Because printer wasn't recognizing the wireless network, I hooked it up via the printer cable. Printer worked. 

 

However, recently, following one of Microsoft's routine updates, the printer delivered a "printer not responding" error message. I rebooted and reinstalled the printer software from the disk. It still wouldn't print. I ran the troubleshooting program and it found no problems. I hit test print and it printed. However, when I tried to print something from my browser (Fandango movie tickets) it gave me an error message. 

 

In sum: I'm at a complete loss. My printer won't connect via wireless (won't recognize network) and now it won't print via cable. I've reinstalled the software from disk, rebooted, etc., and have run out options. Any ideas appreciated. 

 

Thanks

 

2 REPLIES 2

kob6
Apprentice

Update: The USB now works. Apparently, the black and blue inks were low. Once I replaced them, it started working. 

 

However, the printer still doesnt' recognize my wireless network, doesn't display it at all, although it shows the other wireless networks in my building. The wireless network works fine. 

Michael
Product Expert
Product Expert

Hello kob6.

 

If your WiFi router is not listed in the network list, it may be possible that the SSID is not being broadcasted from the router.  Please check the settings for your router to see if this is the case.

 

If you continue to have difficulties, we recommend that you contact our support group using the "Contact Us" link below.

 

This didn't answer your question or issue? Find more help at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM