cancel
Showing results forย 
Search instead forย 
Did you mean:ย 

Did Clean install Windows 11 Now Will not install Printer or Software Correctly

briankconner
Apprentice

Yes, I have a Canon color image Class MF642 Cdw. I did a clean install of Windows 11. Now when I try and install the printer from the software disc it gets to the point of plug-in printer and turn it on. I have tried this numerous times and it just sits there and nothing happens. I have tried installing it through windows 11 but it does not install correctly. I have tried the new drivers and still no luck. When I was able to get it to work one time. I tried installing the scanner and toner software. but it can not find the printer. The one time it actually installed it had 3 canon printers in the printer section. I have done a hard reset on my printer and reset it up ahead of time. Can anyone please help? It was installed and worked just fine in windows 10 with no issues. Thanks, Canon Community!! ๐Ÿ™‚

5 REPLIES 5

Tronhard
Authority

I suspect that this is more of a Windows 11 issue.  I worked on a couple of releases of Windows back in the day and it usually takes them a while to get the interface with the huge multitude of drivers they have to deal with.  It is for that reason that I have held back from installing Windows 11 myself!

cheers Trevor

"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
"A good swordsman is more important than a good sword" Amit Kalantri

Technique will always Outlast Tech - Me

Morning Sir Thanks for your input. I usually don't go this early for a new operating system. But just bit the bullet just one time and it hit hard lol. But I was finally able to get it installed correctly. I was reading stuff on the internet and came across a post about doing it by wifi instead of USB cable and it did work. The only difference was when I updated the drivers you had to accept the survey option or it canceled the install. 

shadowsports
Elite

@briankconner,

Greetings.

When you say you tried "the new drivers"...  does that mean you downloaded the Windows 11 specific drives listed on the MF642Cdw support page?

Support | Color Laser | Color imageCLASS MF642Cdw | Canon USA

Windows 11 drivers were released earlier this month 12/3.  Its unlikely the CD that came with your printer included drivers supporting your new OS.  If you have 3 instances of the printer installed, I'd be surprised if any if them worked.  What might help.  Use System Restore and go back to a date and point in time before you attempted install using an old disc.  Other option, remove the (multiple) failed instances of the printer from Settings > Control Panel > Device and Printers, and uninstall any installed Canon programs / drivers, then restart.  Now use the correct driver for Windows 11 to install.  

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Good morning yes I went to the official canon website and got their latest drivers. But was finally able to get it installed by doing it through wifi and not a USB cable. I hope it is fixed soon i like it to be hooked to my computer compared to wifi. Thanks For Your Help.

 

DiAnneInDover
Apprentice

I could have written Brian's exact post. 

I reformatted my computer 2 weeks ago. I had Windows 11 for a month before that and my MF8350cdn worked fine on Win11. But after reformatting, I can't install the printer. I tried from the website drivers, and no luck. I get to the point that it says "Plug in the USB cord" and then it stops and nothing more happens. When trying to print, my computer thinks I have a Fax machine and a scanner but no printer. 

Unlike Brian, when I tried to do the network install that didn't help (because I still can't get a driver to install).

I even went in and used the old CD installer. It went all the way through and finished the installation and even got to the point where it said "restart your computer." But same result. It never had me do any of finalizing things and I still only have Fax and scanner. 

Again, it worked on Win11 until I reformatted. I even saved the drivers on my external hard drive before reformatting and used those. But I cannot get the installer to get to that point. 

It's 3 months later. I'm not the only one who has had this exact issue. Any luck? I have an expensive machine (not new, but works great) and $700 worth of just opened toner cartridges sitting there, and I'm so irritated. 

Announcements