cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't connect PIXMA MX922 to WiFi

themaclady
Contributor

Got a new modem. Instructions say to press button on back, which turns out is wrong because it just resets and takes you offline.

Now I am back online and I see my network in the list on the printer, but connecting that way does nothing either.

It does not ask me for a passphrase or number.

Called but they won't help, hung up on me.

PLEASE! I'm desperate to get my printer back working.

2 ACCEPTED SOLUTIONS

themaclady
Contributor

ON MY GOSH! Simple fix! THANK YOU DAVID!

Called Canon again and he told me that the router was TOO CLOSE to the printer. Yes it was 6" away, never did I think that would be an issue since it was seeing all the neighbor's networks, an acre away, but not mine!?

After we cleared all the LAN settings I moved the printer just a few more feet away and VOILA! We are finally online. I knew there was some simple solution since I had seen the network show up on the screen once before, but then mostly not. I did not know what was stopping it from showing up again.

Who knew the new routers had a 'trunk' signal distance and that if your router is too close it could be a problem? I always thought it being too far away was an issue, but never too close.

 

View solution in original post

Yes, this was my problem too.  Don't understand what happened.  I might have moved them closer together but suddenly the printer stopped working with the same symptoms.  Moved them a few inches apart and then it all worked fine.

View solution in original post

8 REPLIES 8

Danny
Moderator
Moderator

Thanks for joining the conversation, themaclady!

This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or register your Canon gear HERE to access additional support options.

Thanks and have a great day!

I signed up and paid $20 for an answer that did not work.

If the solution you were provided didn't work, you're welcome to call back at no additional charge within a certain number of days.  Our PIXMA support team is committed to finding a resolution that fixes the issue permanently.

We look forward to your call!

OK I did not know.. thought I had to pay each time.

I am not getting the help I need! I have set up three bands, 2.4, 5 and 6. I set the 2.4 on WPA2 and it still doesn't even SEE the network... the router is sitting right next to the printer.

Why can't anyone help me with this?

themaclady
Contributor

ON MY GOSH! Simple fix! THANK YOU DAVID!

Called Canon again and he told me that the router was TOO CLOSE to the printer. Yes it was 6" away, never did I think that would be an issue since it was seeing all the neighbor's networks, an acre away, but not mine!?

After we cleared all the LAN settings I moved the printer just a few more feet away and VOILA! We are finally online. I knew there was some simple solution since I had seen the network show up on the screen once before, but then mostly not. I did not know what was stopping it from showing up again.

Who knew the new routers had a 'trunk' signal distance and that if your router is too close it could be a problem? I always thought it being too far away was an issue, but never too close.

 

Yes, this was my problem too.  Don't understand what happened.  I might have moved them closer together but suddenly the printer stopped working with the same symptoms.  Moved them a few inches apart and then it all worked fine.

What gets me is, Canon knew about this but after hours of discussion with Comcast not one of their techs suggested it and this is their new router!

Avatar
click here to view the press release
Announcements