Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎08-09-2019

MG5220 - Cannot Start MP Navigator EX

We have a PIXMA MG5220, setup for wireless.  It has worked fine for years for printing and scanning.  We have one PC and one Mac.  Recently replaced the PC with a new Dell XPS running Windows 10 x64 Home.  Installed the current printer drivers and the MP Navigator EX software.  Printer works fine.  When we launch the Navigator software, however, we immediately get an error saying 'Cannot start the MP Navigator EX'.  

 

Troubleshooting tried:

- Un/Reinstalled Navigator from support page

- Uninstalled Navigator and reinstalled using Windows 7 compatibility mode

- Successfully scanned using 'Fax and Scan' & 'Microsoft Scan' applications, proving that the driver is working and the scanner is reachable.  So problem is with the Navigator application, specifically.  However, scan size and multipage limitations in these applications prevent using them in place of Navigator.

 

This is a new machine and this is the only printer/scanner software installed. Clearly the scanner works and is reachable, but the Navigator program won't work.  Any ideas what the issue is with the program?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement