Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎12-28-2015

ELPH350HS - cant connect my camera to my PC

I just got a ELPH350HS, and am having all sorts of trouble connecting to my computer.  I tried to connect by adding an access point and that seemed to go ok, then it doesn't connect or times out or something.  I tried the WPS method and that did the same thing.  To feel like I was making progress with something,  I reviewed the user manual again and it looked like I should download the digital camera software 5.1, so I tried to do that.  That didn't work either, because it won't take the serial number from the side of the box.  Nothing I do is moving me forward in the process of connecting to my computer.  Where do I go from here?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement