cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Suddenly Computer doesn't detect SX30 IS

fritzmom
Contributor

Hello

Windows 7 32 bit SP1 - nothing has been changed by me on the computer in the last while - maybe Windows??

Canon SX30 IS

I also have a Canon PowerShot A530 that we still use and download to the same computer

 

The last time I downloaded pictures from the Camera's memory card to my computer was in February. In March I downloaded pictures from the A530's Camera to this computer. Today I went to download from the SX30 and the computer cannot dedect the camera at all. I have not tried to see if the computer dedects the A530. I have used both USB cables from both of the Canon cameras. I don't have a memory card reader so I have no other way to get those pictures onto my computer.

 

Thinking I needed to update drivers, I downloaded cdw-inst-8-8-0-17-u01-9l and installed - nothing happened

I downloaded IBXW_INST_1_4_0_5_U01_9L but could NOT install because it could not 'verify' my camera - it couldn't dedect the camera.

 

I have also checked under Device Manager while the camera is attached to the computer, but it does NOT show up under Imaging Devices or Portable Devices or anywhere else.

 

Help please.

I also tried to create an account to email Support, but for some reason i cannot create an account. As it's the weekend I can't even phone. I am in Canada by the way.

 

Help would be more than much appreciated.

Barb

(edited for Device Manager info)

5 REPLIES 5

fritzmom
Contributor

Since I can't edit my original post:

 

Since I first posted,

I attached my other PowerShot A530 but the computer does NOT detect that camera either

 

I have tried both USB ports on the front of the computer, neither sees either camera

 

I have tested both front USB ports with another USB device, and the device is recognized - so no problem with USB ports

 

B

John_
Authority
Before you installed that software did you unistall the old software first ? It sounds like either a registry problem or a device manger problem to me

I installed the software for the SX30 over 4 years ago, I don't remember if I uninstalled the previous Canon software.

 

BUT, I've had no problems for the last 4+ years until now.

John

Please accept my apologies for my previous reply to you being so curt.

 

Thank you for your suggestion as to what might be the problem with my cameras. I'll look into what might be wrong if it is a registry or device manager problem(s). Maybe Windows did an update that did something?

 

I'll give it a couple of days then I'll uninstall the software and reinstall it and see if that works.

 

Thank you again, and again, my apologies.

 

Barb

Hi Barb dont be silly there are no apologies needed !

I have Windows 8 and it has done some updates that have caused me some problems which could be what happened to you.

All this technology is awesome until something like this happens and it can be very mysterious and frustrating.

 

 I have a problem now with my printer and this computer for some unknown reason something happened to the "print spooler" and I can no longer print from this computer. A term I wasnt very fmiliar with, print spooler, and it seems there is no cure for me other than reinstalling windows 8...I've had this computer for about 3 years and reinstalling th OS and all the other programs I have would be a total nightmare to me so I am living with my "print spoler" problem after days of Google searches an trying different things lol

 

Give it a try when you get a chance

No harm no foul Barb !

Avatar
click here to view the gallery
Announcements