Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS MF733Cdw AirPrint issue


Good day,

I wanted to ask a question regarding the Mac compatibility of the MF733Cdw.


We have a 733 that we are using in our home office, it worked great for the first year/year and a half and then we started having connectivity issues. The issues were small at first where the odd time we couldn’t print from our iPhone’s using AirPrint, then it started where the Mac laptop couldn’t find the printer to print. And now the issues have worked up to the point where no matter what we do we can’t AirPrint from our iPhones and the Mac laptops will not find the printer. The only way we can now print is using the Canon business print app on the iPhones. 

is this an issue others have seen? Is there a solution to the issue or is it time to replace the printer? 


A little background,

I have spent hours and hours on this issue with no positive result. I have contacted Canon tech support and we have gone through everything possible it seems including a hard reset of the printer using the touch screen display. I have tried the printer on wireless and wired network, and even went as far as buying a second router to trouble shoot with. I have also bought a third router to try and expand the wifi signal when testing the printer on wifi. 


At one point I was able to get the printer to work by switching off and on the AirPrint setting in the printer but that no longer works not either. 

I hate to toss anything in the garbage that could be fixed, maybe it needs a new printer network card? I am looking for any feedback possible. I would consider replacing the printer with the MF644Cdw, it’s a bit of a downgrade from the 733 but my concern is that the same will happen to the 644 in the future? The 644 was released in 2019 and we haven’t seen any new image class printers released in Canada since then. 

It just doesn’t make sense to me that the Printer can be found by the Canon Business print app but not by the phones or laptops when not using the app. I’m pulling my hair out, any input would be greatly appreciated.






Did a lot of reading today on this site and tried setting a manual ip address through the webpage for the printer. Also set the router to DHCP reserve/entered printer MAC address and entered the same ip address that I entered into the printer.

I have turned on mDNS also as I wanted to give that a try. I made sure the printer is plugged into the wired LAN, restarted the router, laptop and iPhones. It worked for all of maybe 5 mins on the phones before I had to login to the printer webpage and turn off/on air print and then the printer was seen again for a few minutes and then no luck on the phones. 

I sure don’t understand why the printer is doing this but I’m really starting to think it’s a printer issue. And further more I believe it’s a firmware issue that could be resolved by Canon. I could be totally wrong… I just want what I paid for to work. I certainly won’t be buying the MF644Cdw as I see a couple people on this site have the same issue as I am experiencing. 

Anyone have any other ideas to try? 

Buying the MF644cdw will not solve your problem as I have the same issue. Airprinting worked besutifully when I first bought my printer, however, one day it stopped. Although I hsve set a ststic ip address, the printer changes it every time it goes to sleep. I have to manually reset it every single time I want to print. Nothing else works. It's not a router issue, it's a firmware issue. This has been ongoing for several years now but apparently not enough people report it to escalate it to a fix. I should have never switched printer brands after years of loyalty to Epson. Such a headache.

I appreciate the feedback and am happy you mentioned that the 644 does the same thing, you have saved me headache and money. 

I will be in touch again with Canon regarding this issue, I will also touch base with my router manufacturer. I have the DHCP set to reserve/auto assign an ip address to the printer and a static ip entered into the printer. But I am seeing in my router that the printer is showing offline only after a few minutes of cycling the printer power. Not sure what is going on here but I hope I can get to the bottom of it. 


Sounds like a poor experience.  I have a MF644cdw.  Its connected to via ethernet to my router and is using a static IP.  I can ping it, and reach its webserver 24/7.  I can print from my Android Pixel.  I have an iPAD but haven't tried printing from it.  I'm a primarily a windows user, but my MBP prints to it as well.  Sorry I don't have more to add.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


Spent another half hour on the phone with Canon tech support. They have run out of options for troubleshooting and are going to escalate the issue. I was told to expect a call back tomorrow with an update. 

I have also spent quite a bit of time with tech support for my router. Synology has been great at looking into debug logs and network logs generated by the Rt6600ax router. They can find no issues with the router or the way it is handling network traffic. 

Even with a static up set in the printer and the same ip address reserved in the router I still am having no luck being able to print. I still have to power cycle the printer or log in to the web interface and turn off and on AirPrint. This is only a solution for about 5 minutes and then it needs to be done again. So basically every time we need to print.

I am really hoping Canon has a solution to this problem.


Well just to close off this thread, spoke with tech support again and they escalated the issue to their next level support team. 

I was told it’s likely a hardware issue and to send the printer in for service. I’m not willing to drive the printer 4hrs one way to the canon service center, and not willing to ship the heavy boat anchor there either as it will cost an arm and a leg. 

I have given up on this issue and will just buy a new printer. Too bad they won’t look into possible firmware issues on their end. As I’m fairly sure it’s not a hardware issue. The printer will do all the proper things except AirPrint. Turning off and on AirPrint every time only to have access for about 5 mins is not a solution to me. 

Thanks for the update. Disappointed in their assessment. It’s back to Epson for me. 

Yeah I’m super disappointed too, especially since the printer never really worked that great from the start for air print.

I was offered a discount for a new printer…… what I wanted was for them to look into the firmware. 

I wonder if you can buy parts for this printer? If it’s cheap enough I might look at changing out the network board if I can find it…. Just a thought though 

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5