Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS D340 Windows 10 21H2 now won't print


Everything was working fine until the most recent Windows 10 November 2021 update installed on it's own.  Now, I just get " Error - Printing ". 

I have tried uninstalling - reinstalling the latest driver.

I've researched older drivers to see if they might be compatible; they are not.

I've tried deleting the driver and letting Windows install from Windows Updates; no luck.

I fix computers for a living and this is aggravating, not that it's Canon's fault, this much I know.  Basically, I'm going to have to tell my parents that they're not going to be able to print unless we either downgrade Windows to a version prior to the November 21H2 update, wait for Microsoft to release a new update, wait for Canon to release a new digitally signed driver, or, you guessed it; get a new printer, after we had just bought ink.

Any ideas?  Google has not been kind.  I am very open to anything that anyone would want to try.




With the printer installed and connected, what does the USB bus look like in Device Manager?

Any issues reported there?

Is the printer connected directly to a USB port, or is in connected to a hub or adapter of some sort?

The device is 14 years old.  Maybe it is time for something new.  


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I will take a look and report back, thanks for the advice.

Printer connected directly to a USB port to the back of the desktop.

Earlier was showing a yellow exclamation point next to a driver relating to either a scanner or scsi or something or another, I should have taken a picture.

Printer was working out great for us up to this point, hard to believe that we're contingent on an update from Microsoft to fix this issue, there's no telling how long that could take.

If there was some sort of workaround in the meantime, we'd even be willing to accept that, as well.

Although 14 years old, it should still be able to handle a basic print job.


I'm having the same problem and have a new expensive printer cartridge that I purchased through Canon.  Did you figure anything out?  PLEASE !!!

Are you running Windows 10 or 11?
Right click an empty space on your desktop, then select display settings. On the settings, screen that appears, on the left-hand side panel, scroll down to the bottom, and click on where it says about. There should be an edition, we would need that, along with the version number right below it. Let’s have you download and install, manually, using the offline Windows 10 22H2 update

Would you mind letting me know, once this has been tried, and whether or not you are successful?

Hello MichaelStewart, 

In this situation, you can try removing any USB connections for the printer under device manager and trying a reinstall of the imageCLASS D340/D320/FAXPHONE L170/L120 CARPS Printer Driver from our Canon USA support site. Before installing the driver, you can remove any connections for the printer from device manager. 

You can press the Windows key and the letter R key at the same time on your keyboard. In the run box that appears, you can type in devmgmt.msc and click OK. Under universal serial bus controllers, you can right click and select uninstall device for any of the USB printing support connections associated with the printer or any listings of the printer name. 

Once the connections are gone, you can disconnect the printer from the computer and try installing the drivers. You can connect the USB cable again when the setup prompts the connection.

Once reconnected, you can try printing again to see if it works or if you get any specific error messages.