Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎04-15-2018

Scan to email quit working on MF8580CDW

[ Edited ]

(With apologies to the many other similar threads... I've read them all, and still having trouble)


I've put together a ton of screenshots that show the errors, my settings, and what I've already tried, take a look.


Have a MF8580CDW, connected to wifi. 

Trying to use scan-to-email, with a GMail account. 

But it gives error #752 every time. 


Background: It was working great for a long time, and the error began recently when someone pulled out the power cord, and the printer lost all its settings. Now I can't get it to work again.


Troubleshoting done so far:

Yes, the printer is connected to internet.

Yes, I'm pretty sure I have typed in the server name and username correctly.

Yes, the gmail account has "allow less secure apps" turned on. 

Yes, I have changed the SMTP port number. Tried 25, 465, and 587. All give same error - Error #752.


Please take a look at screenshots of everything: screenshots.


Can anyone suggest additional troubleshooting?  Thanks.






Occasional Contributor
Posts: 5
Registered: ‎01-22-2020

Re: Scan to email quit working on MF8580CDW

Me Too.


Set up via 587 TLS, tested, worked fine.


A few days later, it quit working with no configuration change.


This is a imageClass D1620, however.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement