cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF642C/643C/644C UFR II not printing

eyedoctor
Apprentice

We previously could print off the above printer from our computers, phones, etc wirelessly. 

 

For some reason today it stopped working for no apparent reason from all of our devices. 

 

Error Printing on .. Printer couldn't print...

 

I've tried shutting it down, and restarting. Disconnecting the power and then plugging directly into the wall after ten minutes.

 

During this time it said it had good wifi connection. 

 

I tried to update firmware on it but get this message:

"Communication error occured. Cannot check the firmware version"

 

I went to menu - initialize all data settings as this appears to reformat the device. I've completed this, and it says it is connected to WIFI, but when I look on my router it is not connecting. I directly wired a ethernet cable into it and am getting the same issue.

 

In summary, there appears to be a problem with the printer recieving information. The printer thinks its connected to WIFI when it isn't. Directly connecting a ethernet line does not solve the issue either. Please help,

Tim

2 REPLIES 2

Greetings,

We're not sure which printer you own based on your thread's title, but all of the ones you listed should be set to DHCP (by default) and would receive an IP address when connected to a router via ethernet or wireless.

 

If you do not see the printer, in the connected or attached devices list on the router, then it's probably not connected.  You'll have to solve this issue before you can install or update the printer.   

 

The steps for confirming DHCP is enabled on the printer is the same across several models.  Here is an example:

 

Setting IPv4 Address - Canon - imageCLASS MF746Cdw / MF745Cdw / MF743Cdw / MF741Cdw / MF644Cdw / MF6...

 

There is no way for us to verify what the router is doing or how it is configured from where we sit here.

~Rick
Bay Area - CA


~R5 C (1.0.2.1) ~RF Trinity, ~RF 100~400, +Canon Control Ring

~6D2 (v1.1.1) Retiring ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Hector
Product Expert
Product Expert

Hello Eyedoctor,

 

If you have switched from wifi to ethernet, you can try checking the wired/wirless setting using the steps in the link HERE. If it is set to the wired option, you can check the printer's setting to check if it has a valid ip address. You can view the printer's ip address using the steps HERE.

 

Once you have the printer's IPv4 address, you can try opening a web page on one of the computers/mobiles devices and enter the IPv4 address into your address bar to see if it can access the web interface for the printer.

 

If it can. You can try printing from your phone or computer to see if it can communicate. If you can't reach the ip, address, I would suggest contacting support at 1-800-652-2666. Our agents would be happy to help check what is causing the communication issue.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.