Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

435 REPLIES 435

Toolbox 4.9 not working with mf216n.

Hello Cannon support team,

I have the same of similar issue after downloading MF Toolbox Version for Windows, it does not work on my MSFT Surface running Windows10.


When I open the MF Toolbox program it diesplay an error message window with the following:

"A supported scanner is not installed" "Please install a supported scanner and restart Toolbox"


My scanner is supported in my other computer running Windows7 Professional, SP1. This is a Dell PC (64bit OS) and its been working fine for a couple of years.


Is there a solution to this problem of incompatibility with Windows10 OS? On the forum it seems to be a very common issue.

Can you help me?

Thank you.




Hi, mzamarri!

Welcome to the Canon Forums and thanks for your post!

To have a better understanding of your issue, please let everyone know the model of the product you have. That way, the community will be able to assist you with suggestions appropriate for your product.

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).


4 calls to Tech support has no solution and claimed it was a customer PC problem, but a 3rd party VueScan has no issues and is more comprehensive than the Canon Toolbox 4.9.

Possible workaround:


Since behavior seemed to be some inter-process lock, I tried to stop as many background processes at notification area as possible, and some of those unlocked setup.


Processes I closed were:

  • google chrome
  • skype
  • line
  • creative cloud
  • adobe updater
  • ccleaner
  • iTunes
  • onedrive

and several more.

one of these processes dead-locks toolbox setup.


after exiting/quiting/stopping all of these I was able to finally successfully install ToolBox_4911mf17_Win_EN.exe on windows 10 (current version on Nov 26, 2015)

Dear Team, I am facing the same issue which facing by Mr. Mzamarri, I am using canon ImageRunner2002N. Kindly help me to resolve this issue.

Hi, harshali!

Thanks for posting! While our forum community members are welcome to chime in, Canon does not provide direct support for imageRUNNER series products. Instead, your dealer will be able to help you! If you don't have a dealer and you're in the United States, please call us at 1-800-OK-CANON (1-800-652-2666) and we will be happy to provide you with the names of dealers in your area.

If you're outside the USA, visit and choose your country or region from the map for local support.

We hope this helps!

I apologize of this information has already been posted.   For my scanner (MF4770n), there is a software patch on the Cannon web site where you download drivers.   Instructions are to install the dirver, restart the computer, and then install the patch.  Worked for me.   Says that the patch might have to be applied again if windows 10 is updated.  

Thanks for the tip about booting into safe mode - that was exactly what I needed.  I also re-installed both the Toolbox and printer drivers in Safe Mode as well.  Everything is working great now!

I had the same problem with the uninstall but I just rebooted and it worked fine the second time.
click here to view the gallery