Canon Community Canon Community

Occasional Contributor
Posts: 9
Registered: ‎11-19-2015

Re: MF Toolbox doesn't work on Windows 10

The toolbox icons for .pdf and ocr do not look the same. Clicking on any buttons would not bring up the dialog box.

Occasional Contributor
Posts: 9
Registered: ‎11-19-2015

Re: MF Toolbox doesn't work on Windows 10

Does not work for me. Ethernet cable connected to router.

Occasional Contributor
Posts: 9
Registered: ‎11-19-2015

Re: MF Toolbox doesn't work on Windows 10

A third party VueScan utility works great and is more comprehensive than ToolBox 4.9.. Costs $40. Canon has better shape up and fix its sofware instead of blaming the problem is with the customer's computer.

New Contributor
Posts: 1
Registered: ‎11-25-2015

Re: MF Toolbox doesn't work on Windows 10

Hello Cannon support team,

I have the same of similar issue after downloading MF Toolbox Version for Windows, it does not work on my MSFT Surface running Windows10.


When I open the MF Toolbox program it diesplay an error message window with the following:

"A supported scanner is not installed" "Please install a supported scanner and restart Toolbox"


My scanner is supported in my other computer running Windows7 Professional, SP1. This is a Dell PC (64bit OS) and its been working fine for a couple of years.


Is there a solution to this problem of incompatibility with Windows10 OS? On the forum it seems to be a very common issue.

Can you help me?

Thank you.




Reputable Contributor
Posts: 861
Registered: ‎10-12-2012

Re: MF Toolbox doesn't work on Windows 10

Hi, mzamarri!

Welcome to the Canon Forums and thanks for your post!

To have a better understanding of your issue, please let everyone know the model of the product you have. That way, the community will be able to assist you with suggestions appropriate for your product.

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).


Occasional Contributor
Posts: 9
Registered: ‎11-19-2015

Re: MF Toolbox doesn't work on Windows 10

4 calls to Tech support has no solution and claimed it was a customer PC problem, but a 3rd party VueScan has no issues and is more comprehensive than the Canon Toolbox 4.9.

New Contributor
Posts: 1
Registered: ‎11-26-2015

Re: MF Toolbox doesn't work on Windows 10

Possible workaround:


Since behavior seemed to be some inter-process lock, I tried to stop as many background processes at notification area as possible, and some of those unlocked setup.


Processes I closed were:

  • google chrome
  • skype
  • line
  • creative cloud
  • adobe updater
  • ccleaner
  • iTunes
  • onedrive

and several more.

one of these processes dead-locks toolbox setup.


after exiting/quiting/stopping all of these I was able to finally successfully install ToolBox_4911mf17_Win_EN.exe on windows 10 (current version on Nov 26, 2015)

New Contributor
Posts: 2
Registered: ‎12-02-2015

Re: MF Toolbox doesn't work on Windows 10

[ Edited ]

I have the latest version of Windows 10 that came out in fall 2015. I used to be able to scan, but after the update, it didn't work. Here is my list of things to get the scan function working...


  1. I already had the printer driver installed. I think mine was a 64-bit driver for Windows Vista/7/8/8.1. The scanner driver seems to be included in this.
  2. Installed the old MFC scanner driver. Actually, it's a program not driver. It is called Canon Toolbox. Mine is an ImageClass MFC5770 with USB and Network connection. As always, I the scanning function will only work with the USB connection on this type of old multifunction.
  3. At this point I found out that Canon Toolbox will not run, even with compatibility settings. I think it used to run on Windows 10, but no more worky for me.
  4. Per another person's tip, I installed and ran the Microsoft Scan app from the Windows 10 Store. It did not work. I could do a Preview scan and see a portion of a page. But the scan function had an error "something went wrong."
  5. I tried a regular scan from a standard program rather than an app. In my case, I have already installed Foxit Reader PDF software. Other PDF and photo editing software likely has this ... Adobe Acrobat does. Hamrick software has a lot of scanner software, like Vueprint and others.
  6. From the program's menu, I selected "From Scanner" to begin a scan. It has a simple menu, it detected my WIA scanner driver (very important) and was able to scan like the olden days with Canon's scanner driver interface.
  7. I was able to save a PDF, and it gives options to scan multiple pages to PDF.
  8. Did I mention that Foxit Reader is free?!
  9. Note: Changing the startup options for the WIA service did not work for me. To try that, see and scroll to Piers_A's solution.

This means to me that Microsoft has hidden or obfuscated the old, tried-and-true WIA scanning interface. It is apparently still available somehow to the older programs that use this. I think WIA is actually newer than the older TWAIN driver, but I am not sure. Anyway, try the programs I mentioned and see if they can work for you.


One more thing: I have my Canon printer on the network and connected to USB. I am assuming the scanning happens over USB, but I have heard WIA works over a network.

Occasional Contributor
Posts: 8
Registered: ‎12-07-2015

Re: MF Toolbox doesn't work on Windows 10

[ Edited ]

SORRY - this reply was intended for Piers_A and Captret.


Many, many thanks. I entered the changes you recommended and it worked not only the first time but I’ve been using it for the past week without a problem.

Occasional Contributor
Posts: 6
Registered: ‎11-16-2015

Re: MF Toolbox doesn't work on Windows 10

[ Edited ]

"Start> in the run box type. Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply."


This was posted awhile back(msg 23) in this thread. PiersA, and originally somewhere by Captret.

I wish people would just do their research and take time to read through a thread instead of just repeatedly asking a question and expecting it to be handed to them on a plate.

The response above has helped ALOT of people. Its SIMPLE, its EASY, it WORKS for many people- including me.

Try it, and if it works, thank(kudos) PiersA and Captret. That way when others go through the thread they can see that post got lots of kudos and therefore is a good bet.

In this way you also help others instead of just yourself.

Rant over.... :-/

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement