Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF 4350d - MF Toolbox "Installation has been interrupted"


Hi everyone.  I am using an imageclass MF4350d with Windows 10.  I noticed that there were two copies of this printer showing up on my computer, which was mildly annoying, and so I decided to uninstall and reinstall everything to try to fix that.  However, when I do that, I now can't get the printer to work at all!


Specifically, I first installed the driver from the Canon website, which seemed to go just fine.  But next I tried installing the toolbox (the file is ToolBox4911mf18WinEn and it is MF Toolbox 4.9), which doesn't work.  I keep getting a message saying "Installation has been interrupted.  The wizard was interrupted before MF Toolbox could be completely installed.  To install the program at a later time, run Setup Wizard to perform the setup process again."  I get the same result when trying to install the software directly from the CD I got when purchasing the printer.


Any suggestions?



Hi pelahi.


If the MF Toolbox is not installing correctly, try restarting the computer, then running the installation again.  You may need to right-click the installation and select "Run as Administrator".  If the problem persists, try removing the MF4350d from your printers list, then re-registering it specifically with the UFR II drivers.


You may also need to install the Patch for Network Scan.  It's available, free of charge, on the MF4350d Drivers & Downloads page.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks Darius!  Running as an administrator seemed to do the trick for installing the MF Toolbox.  However, I now have a new problem, which is that the printer doesn't show up on my list of printers even after installing the two drivers (the main one + the one you linked to).  Interestingly, I can scan or copy with the machine, but I can't get it to show up as a printer.  I thought it should automatically show up after plugging in the USB cable, but it doesn't.  And when I go to "Printers & Scanners" on my computer and try to add a printer, the only thing that shows up doesn't look right (DIRECT-84-HP M148F LaserJet) and asks me for a WPS PIN, which I don't think I have.  Any further suggestions?

Hi pelahi.


I'm happy to hear that we got scanning working!


Normally, plugging in the USB cord after the drivers installed would cause the computer to automatically detect and register the printer.  It's possible for that setting to have been turned off.  Alternatively, your security software or firewall may still be blocking the printer's signals, or see it as a duplicate device (and thus suspicious). 


One other possible cause would be if the computer is a laptop, and running on battery power.  USB signals when running on battery can be problematic for the MF4350d.  If the computer is a laptop, ensure it is connected to external power.


Something you can try is to connect the USB cord, then open the computer's Device Manager.  You may need to enter your Admin password.  Once in there, look for an entry in either the Printers or Universal Serial Bus categories for "USB Composite Device," or noted as Canon, with a yellow triangle beside it.  If such an entry is present in those sections, right-click and select Uninstall.  Once the entry is removed, disconnect and reconnect the USB cord between the printer and computer.


Note: The DIRECT entry that shows up is not a Canon entry, and will not connect to the MF4350d.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Darius - thanks again for the help!  It is a laptop, but when I plug in to external power it unfortunately doesn't change things.  And for the Device Monitor idea, I do see two entries called USB Composite Device although neither has a yellow triangle.


You mentioned that it's possible that a setting might be turned off, preventing the computer to automatically recognize the printer.  Is the fix for that what you described about going into the Device Manager, or is there some other way you know of to change that setting?


Thanks again!

Hi pelahi.


Is there a different USB port on the computer to which the printer could be connected?  If so, try disconnecting the USB cord, then plugging it into the other port.  If the MF4350d still isn't detectable as a printer, but is able to scan, then security software on the computer is blocking it, and you'll either need to disable the security software temporarily, or contact the computer's manufacturer for help disabling it.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks again Darius, but no dice.  The printer's a bit old and I actually do have another newer one, so I think maybe it's time for me to use the other one from now on.