cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MAXIFY MB2020 Problem with changing my ink cartridges

SalBurrows
Apprentice

I have a older model MB2020 canon printer. Last month when my black ink finished I went to staples to get a new cartridge to replace the ink. Before this we were using an amazon brand. Everything seemed to be okay when I installed the new cartridge in and ran a test page. As we started to use it we noticed our print outs were starting to get more streaky so we ran some nozzle cleaning and deep cleaning cycles but it wasn't improving and in fact getting worse and then the black ink started to not appear at all. The printer was not detecting that we were not getting any ink on our pages. So I figured why not just keep printing something until it detects it or the computer will tell me to replace the cartridge when no ink was detected. Well that didn't happen. Instead of telling me my ink was empty a question mark appeared on to of the black ink instead of an exclamation mark to tell me to change the cartridge. When I clicked on this question mark it would tell me that the printer cannot detect the ink levels and an error code of 1660 would appear. I clearly remember hearing the click when installing it and it accepted it. Now I cannot access the cartridges at all to change it. We tried several troubleshoots on the canon website and nothing has worked. Can someone please help? It worked just fine before this happened. Thank you.

1 REPLY 1

dexman335
Rising Star
Rising Star

Is the new ink Canon OEM or an alternate brand? 🤔

Avatar
click here to view the gallery
Announcements