Showing results for 
Show  only  | Search instead for 
Did you mean: unable to navigate-purchase-log in


I posted something before with the same type of issue before regarding the website!

Am I the only one that has issues with the website?

I am now able to log in, before I couldn't log in at all. I am able to navigate the website and search for items add them to my cart, when I go to the checkout and asks me to log in, first the cart turns out to be empty upon me login in, and once I am logged in, I now cannot navigate the website, I keep getting a message:

This page isn’t working redirected you too many times.

that I need to clear my cookies. I have cleared my cookies a million times and this still happens. I am trying to order ink for my printer and I am unable to. Why is a website so hard to do what it needs to do? Super frustrating. 
I have tried multiple browsers and same happens every time in any browser.


I personally have not experienced any issues with the Canon USA website, the support portal. product registration, with shopping, purchasing or order tracking.  I just bought something that was delivered yesterday.  

What OS are you using?  What browser are you running? 

Here are some suggestions.  Try opening your browser in InPrivate or Incognito mode.  Maybe you have a browser extension installed that is causing issues. 

Have you tried another browser?  Chrome or Firefox instead of Safari or Edge?  

I'd like to help, but am not able to reproduce the behavior you seem to be experiencing.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

I have tried it on windows 11, windows 10, on chrome, edge eve in incognito. My solution atm was checkout as guest. When i enter my email the system tells me that there is an account registered with that email. Which then i have the option of continuing as guest or sign in, if i sign in, a message pops up saying "this account isnt registered with this website". Then the cart is empty etc. So i trey everything again and tried register account (since its telling me its not registered) but then tells me the email is already in use. So the only way atm i can order things is continue as guest. I have co ta t canon about this, but its crickets....super frustrating.


Hi!  If you're having trouble making a purchase through our web site, we recommend giving our sales team a call at 1-800-385-2155.  They're open weekdays and Saturdays and we're confident they can get your situation straightened out.

Hope to talk to you soon!

Thanks Danny.


Thanks for this additional information.  So you aren't actually having a problem viewing the site, but instead with the account you are using to log in and make purchases with.  Early last year, I heard of one other user who experienced this problem where the email address or account they were using could not be used t make purchases. This is something the web services team will probably need to assist with.  The first step is contacting the sales team as Danny suggested.  They can assist with the ink/toner purchase and escalate the account issue if needed.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It