cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

My image Garden

timfc0649
Apprentice

Every time I try to use My Image Garden, my computer freezes and I have to hold the power button to shut down completely, then re-boot.  Printer is MG5420, Computer is Dell Inspiron 1545, Intel Core 2 Duo 2 ghz, 4gig ram, Windows 7 Home Premium.

 

So far I have been unable to use My Image Garden, and therefore I cannot print on discs (my main reason for buying this printer).

 

Anyone else having this problem? Any solution?

20 REPLIES 20

ebiggs1
Legend
Legend

It should and will and does work with Win 7.  Smiley Happy

I would uninstall and reinstall the software. If you do not have it click here.

 

You need to be sure you remove all traces of the old installation before you reinstall.

You may need this.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

I have Win 7 x64 system, and the darn software freezes each time I give a command. I may be lucky to have one print, but then it's stop. Some times I can press Alt+Ctrl+Del and shut it down, other times I have to reboot the computer to be able to restart My Image Garden as it won't respond to a restart of it. I have looked for updates but apparently there's no update since january '18. I love how I can stop the printer from expanding the borders when I do a full page print, but when you can only do a print once in a while it's not worth it unless it's just for a page or two. I see no Canon support is replying to any questions so I guess I'll just have to stick with prints from Photoshop Elements and scrap the full page prints. 

I too have the problem of MIG starting but then freezing on the start screen. I am using Win 10. Have to use task manager to get going again.

Ramona
Authority

Hi timfc0649,

 

Do you receive any error messages prior to your computer freezing when trying to use My Image Garden?

 

If this is a time-sensitive matter, additional support options are available at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

My Image Garden freezes up on my Toshiba also - this is very frustrating! I wish I hadn't purchased another Canon! Please advise.

Hi Laurel,

 

There may be a program running in the background causing this error to occur.  Rebooting your computer without your normal startup applications running may resolve this issue.  To do this, follow the procedure below:

 1.  Click Start.

 2.  Type MSCONFIG in the Start Search box and press Enter on the keyboard.  If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

 3.  The System Configuration Utility will appear.

 4.  Make a note of which startup selection your computer is set on.  If your startup selection is set to Normal, switch it to Selective Startup by placing the radio button dot next to Selective Startup.

 5.  Under Selective Startup, click to clear the Load Startup Items check box.

 6.  Click the Apply button.

 7.  Click on the Services tab at the top.

 8.  Place a check mark next to 'Hide all Microsoft Services'.  

 9.  Click the Disable All button.

10.  Click Apply.

11.  Click the OK button.

12.  Windows will prompt you to restart your computer; click Restart.

 

When your computer restarts, please attempt to use My Image Garden.

 

To return your computer to normal startup mode, follow steps 1-3 above, put a check in the box next to Load Startup Items, and then choose Normal Startup (if it was set this way initially) and click Apply.  Click on the Services tab and click on the Enable All button. Click Apply, then OK and restart your computer.

 

If you continue to have difficulties, please contact our support group using the following link:

http://www.usa.canon.com/cusa/consumer/standard_display/contact_us_consumer

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

phoenix6873
Apprentice

My Problem is a bit different and should be an easy fix if I can get some "TRUE Tech support troubleshooting" 

 

First Background

 

ASUS Dual Core 3.0 GHz with Hyper  speed Tech

16 GB RAM

10 GB Free on C:\

40 Gb Free on D:\

 

Windows 7 Premium 64bit

Printer - Canon PIXMA MX922

 

I do not believe that this is a driver issue as I am able to communicate with the Printer successfully and do simple Printing from several applications.  The problem is purely with the image garden Software.  The Software appeared to install successfully, there were no error messages.  When the "My Image Garden" Software Starts it just stays at the "Please wait......"  I let this go over night and still the software did not load.

 

Trouble shooting Done:

Uninstalled and reinstalled the original Software - same results

Downloaded latest release of software and installed - same results

Disabled Norton 360 and reinstalled software - same results

 

"TRUE" troubleshooting recommendations:  How to Put the "My Image Garden  Software in Debug mode so that it produces a log file and we can see where the load terminates or stalls

 

I am open to other recommendations

Svetik
Apprentice

My Image Gardne started freezing on our desktop computer. We have tried reinstalling, installing the latest version of the program, but it still does not work. We have tried other options suggested by Patrick here, but still not result. Can anybody help?

 

Thanks!

Same problem here. The ImageGarden software loads, then a logo in front of it that never goes away.

 

Looking at the resource usage in task manager shows three tasks, the primary one is up to 855 meg and climbing???? What the hell is going on here???

Avatar
click here to view the gallery
Announcements