cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Log on issues

2flints
Contributor

Hello,

 

I tried logging on and used my same Email address that has always worked for me.  My username appears at the top of the Canon Community home page, and my email address appears in my account settings page, but I can't get the verification email I keep trying to get.  Doesn't Canon like Microsoft Edge?

 

I've tried so many times, I've lost count.  To post this I had to use a different email and username which I am not comfortable using.  I just want to use my real name and normal Email address.

 

2flints

3 REPLIES 3

Abel
Enthusiast

Hi, 2flintsWe recommend trying to login using a different browser or device. If you’re still having a problem you can reset your password by clicking on ‘Forgot username or password’.

shadowsports
Legend
Legend

Both the old and new edge work fine.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

I tried this too -  ‘Forgot username or password’. several times in fact, but I never get the verification email to verify my email address . . . I've given up, I wish the forum worked as good as my FIVE canons - 3 printers and two scanners!!!!  No loyalty here!

 

2flints 

Avatar
click here to view the press release
Announcements