Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎06-16-2020

Issue with adding product - dissapearing after addition

Can't add my new camera to "MyProducts" list on official site, after adding a camera it's dissapearing from the list for some reason. Unfortunately, support wasn't able to help with it... would be happy to get any suggestions. Thank you in advance.

Highlighted
Esteemed Contributor
Posts: 2,148
Registered: ‎11-19-2017

Re: Issue with adding product - dissapearing after addition

[ Edited ]

Greetings,

Log into your My Canon Account.  

 

Select Product Registration

Now enter the name

Enter Information

Finish Registration

 

After inputting the above, you have to "save" the registration.  What message do you see after this is done?  

~Rick
Bay Area - CA
~6D2 ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100
Highlighted
New Contributor
Posts: 2
Registered: ‎06-16-2020

Re: Issue with adding product - dissapearing after addition

Hi Rick,

 

Thank you for your message.

 

I've done that multiple times, most probably I am getting into undocumented flow, after registration I am getting email that my product was added, but few secs later it's dissapearing from the list my gut feeling says that it's happened after I delete the product with opened support cases.

 

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement