Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility Pro not loading when trying to open on Mac Sonoma 14.3.1



I am trying to use my Canon 77D as a webcam for Zoom and to record videos on OBS as well. 
Therefore, I downloaded EOS Webcam Utility Pro and wanted to subscribe as well. Although, upon downloading I am seeing that the software is not working. 

1. If I am trying to use the camera as webcam in Zoom or in OBS, just a black screen in OBS and a grey screen in Zoom appears - no video.

2. If I am trying to launch the EOS Webcam Utility Pro app - it does not load at all. Does not even quit as well. Need to force quit.

Has anyone else experienced this and do you have any potential solution for this?







It seems like you’re facing issues with the EOS Webcam Utility Pro. Here are some potential solutions:

  1. Close EOS Utility: Ensure that the EOS Utility app is completely closed when using EOS Webcam Utility. Disable the option to start EOS Utility automatically when the camera is connected.
  2. Disable EOS Utility Launcher Service: Before connecting your camera, disable the EOS Utility Launcher Service from the system tray (near the clock). Right-click the camera icon and select “Exit.” Then try using your camera as a webcam via USB.

I hope my suggestion will be help you to solve this issue.

Hey BrandyN11, appreciate you reply.

Although, I tried doing what you mentioned in point 1 but it does not seem to work.

As for point 2, I am on Mac Sonoma, am I supposed to find the EOS Utility Launcher Service on the top right corner of the screen? 

Cannot seem to find anything like that.


i'm going through the exact same issue

I downgraded my mac to MacOS Monterey and it works fine now. That was the only solution left to me. 



Try removing memory card before connecting to webcam utility. Solved my similar issue.