cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam 2.1.18 doesn't work with MacOS Sonoma and breaks EOS Utility 3

gave_up
Apprentice

My setup:  Rebel T7 and Macbook Pro 2021 with M1 Pro on MacOS Sonoma (14.3.1)

The problem:  For the last few years, the connection when using my T7 as a webcam has been very unreliable.  I would have to power cycle, kill app and restart, plug/unplug, start/stop the camera, try new cables, switch from Facetime camera back to EOS webcam,  and just generally mess with the camera to get it to work.  Most of my coworkers associate me with the dreaded "red X" backwards EOS Camera image.  I was using EOS Webcam Utility 2.0.30 and it was buggy, but I could limp by. I dealt with the Apple privacy update and was constantly searching these forums for help. 

Final straw: After upgrading EOS Webcam Utility 2.1.18, which promised Sonoma support, everything broke.  Could not connect at all to EOS Webcam Utility.  Could not connect to EOS Utility 3. So I could not even get pictures off the camera anymore.  I had to uninstall EOS Webcam Utility 2.1.18 just to be able to connect regular EOS utility. Then, I tried to downgrade and reinstall 2.0.30 again, but now it appears broken as well.  Hours wasted trying different combos, searching online for help, and trying to get the darn thing to stream.  

I'm done with using Canon cameras for any sort of webcam use, and in general pretty unlikely to purchase another Canon camera due to the very poor SW support. I just pulled out a Logitech c920 camera that had been sitting in the closet for literally 5+ years, and just plugged it in and it worked perfectly right out of the box. Zero SW downloads required, no fussing around. The image quality isn't quite as good, but at this point it's worlds better than a red X. 

3 REPLIES 3

Hazel_T
Product Expert
Product Expert

Hi gave_up,

I'm sorry to hear you've had such a frustrating experience with our software. There is a setting in OS14 Sonoma to double check for an issue like this. OS14 changed how it works with video devices, and to recognize our cameras you would need to enable Legacy Devices. Apple has posted information on how to do that HERE. If Legacy Devices haven't been enabled on your operating system that would prevent both the EOS Webcam Utility and the EOS Utility from detecting your camera.

If the issue continues another thing to check would be to use a different USB cable. Sometimes if the cable has degraded it can cause communication issues between the software and the camera. If you need a new cable the EOS Rebel T7 uses a Mini-B to Type-A USB cable. That is a standardized cable type that should be available in most electronics stores and online electronics retailers.

Neither of those are the issue. I have already followed the instructions to allow Legacy Devices, and I have a new cable that was working fine before I updated to 2.1.18.  After I uninstall Webcam Utility, I have no issues connecting to EOS Utility 3. So the cable is fine and the camera can be seen by the computer. 

damonfclark
Apprentice

I had same problems.. they eventually updated the webcam utility, but as soon as I disconnect the camera to use it elsewhere, the webcam does not work.  The time i have wasted trying to get it to work is crazy.. 

Avatar
click here to view the gallery
Announcements