cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

utilities not compatible with mac os10.7

smascaro
Apprentice
 
2 REPLIES 2

ebiggs1
Legend
Legend

Update your software to the latest version and hope.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

TCampbell
Elite
Elite

You should have no problem running the EOS utility and other software with 10.7.  I've run them with 10.7 and now with 10.8.  You may need to download updates.

 

You can find the downloads at the Canon website:  http://www.usa.canon.com/cusa/consumer/products/cameras/slr_cameras

 

Pick your specific model camera, then click "Drivers and Software".  

 

I have _occasionally_ found that something wont show up for one version of an OS, but will if I pick another -- really it's just a website error as they don't actually make a different version of the EOS Utilities for different cameras (e.g. the "EOS Utility" for, say, a 7D is the same as it would be for, say, a 5D III and the version that runs with 10.8 is the same as the version that runs with 10.7, etc.)

 

 

Tim Campbell
5D III, 5D IV, 60Da
Avatar
click here to view the gallery
Announcements