Showing results for 
Show  only  | Search instead for 
Did you mean: 

t4i firmware bug


My Rebel T4i often freezes in live view mode and I have to remove the battery to unlock it.

Is it a firmware problem?



@hvirla wrote:

My Rebel T4i often freezes in live view mode and I have to remove the battery to unlock it.

Is it a firmware problem?



Please give us more details of what you are exactly doing when that happens, and what accessories you are using: Card, lens, etc.


Does it also happen with another lens and another memory card?


It shouldn't happen indeed, but just to discard there is something else working wrong instead your camera.




HD Cam Team
Group of photographers and filmmakers using Canon cameras for serious purposes. | |

Thank you. I have the T4i with 18-135mm STM lens kit and a Transcend 32GB Class 10 SD Card.

This event occurs  only using  the Live View  mode for about 2 or 3 minutes, when I turn off the camera and turn it on again, it freezes and does not respond until the battery is removed.



Hello Hvirla,


We are not aware that there is a bug in the firmware of your EOS Rebel T4i camera. We should try resetting your camera using the following steps to try and resolve this issue.

1.  Turn the camera OFF and remove the memory card and battery.

2.  Detach the lens and place it out of the way.  Use the camera body cap to prevent dust from getting inside. 

3.  Let the camera sit for about 20 minutes.

4.  In the interim please clean the lens contacts with a soft, new, lint free micro fiber cloth.  Use the microfiber cloth to gently rub across the lens contacts. 

5.  Put these items back in the camera and turn the power switch to <OFF> and <ON> again.

6.  Using the Mode Dial, change from Auto to Program and back while trying to shoot with the camera. 

7.  Try a different Canon EF lens on the camera.

- Check the camera's on-board flash unit. 

- Try a different card and also check that the card slot is closed securely. 

- Clean the battery contacts or use a fully charged battery. 

If completing the above steps fail to resolve the issue then we recommend sending the camera into the Factory for evaluation.  The root cause should become apparent under Factory service conditions.  To start off the service process, please sign up for a repair on our web site.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have this exact same issue.   T4i 18-135 EFS STM Bunde - 16gig class 10 card.  Lockup in liveview after changing dial program.  All controls become non-responsive.  Removing battery and hard "restarting" camera is only solution.  BTW tried your reset and still random lockup in liveview  after changing dial program.  Please advise -

Hi, jpturner

I carried out all the steps listed by Tim in his replay without result.

Please, check this video from the 15th minute, apparently confirms my theory that it is a firmware problem of this camera that Canon has not solved yet.

Yep and this is its been less than a year and the t5i was announced today... I doubt this problem will ever be addresed now. Dave Dugdale does great reviews BTW.  I hope this is fixed.


This happened to me last October. Thought it was just isolated to a certain batch of cameras but looks like it's still slipping past the factory.  This has to do with Live View and Continuous AF being enabled for a period of time on defective units. The continuous focus hunting makes the batteries hot fast which may be a factor.  Turning Continuous AF off should prevent freezing, but the best solution is to return it for a new one if you can or repair it. Don't wait for a firmware update, because it may not fix the issue.


My replacement still works and I love it. Canon please fix this issue for future users!


I have a similar problem. I have the t4i with a 18/135 STM lens kit and it stops to autofocus and disables manual focus by itself in movie mode until I hard restart it. Even after a restart, sometimes it works sometimes it doesn't (the first time).

I also have the t4i using 18-135 STM lens with 32 gig class 10 memory.

Camera locks, battery must be removed, All focusing ability is lost from time to time In auto as well as manual.

Makes you afraid to touch anything. I believe the issue is worse with the STM lens.. But weren't we suppose to buy this lens to unlock the FULL potential of the camera ?


I work on the side shooting hundreds of wedding videos in Las Vegas. I bought this camera to make the jump to DLSR Video. I'm very unhappy with the results.

No one seems to have the answers really. I bought the camera in January 2013 and before I knew it the t5i was released ??

Just makes you wonder.