Showing results for 
Show  only  | Search instead for 
Did you mean: 

anyone had auto focus quit completely on 1D X after updating from firmware 2.0.3 to 2.0.7


my 1D X just arrived at Newport News Factory Service Center today for diagnosis.

camera was working great with All my lenses (Canon: eos 50mm f1.8; eos 28-135mm is usm; 100mm f2.8 L Macro; 24-70mm f2.8L usm; 70-200mm f2.8L IS usm; 100-400mm f4.5-5.6L IS usm), but after firmware update from v 2.0.3 to version 2.0.7, camera will no longer auto focus, gives me error 1 , no communication to lense, clean contacts.

All lenses still work fine with other Canon cameras i have tried them with, went ahead and cleaned contacts, spoke with Canon Service, tried clearing all camera settings and custom settings and removing both main and c-mos batteries with no change.

only </= 14000 shutter events, i am an amateur landscape photographer, take extremely great care of all my equipment, i have owned 4 other Canon Cameras in the past that had no issues, and the friends that i passed these onto are having no issues with them either, i passed on my care and usage suggestions when they remarked cameras looked like NEW.

part of what i do for a fulltime job, is update firmware/ drivers in electronic modules for communication, and building control systems, i on occassssions see certain boards not accept the newest driver, and i am able to rvert back to an older driver to restore communication and control. The Canon literature states this option is not available.

anyone else have this issue pop up, or have a resolution?

appreciate feedback, waiting for news from factory, hoping they may fix this as good will....


Try downgrade through Eos Utility.

thanks for replying,

i am waiting on response from Canon Factory Center.

will remember that if anyone has same issue , problem may be i use Mac's and i have been told the Canon software isnt written with same functionality as PC version...?

have been using other software for my editing , (Photoshop  cs6, Photomatix5.0.5, Helicon Focus, Lightroom4), i shoot entirely in raw,

have only used eos utility once to remotely control my 5D MkII to do some portrait (mugshots) for work.

could have possibly saved some cash, wish i had thought to try this prior to sending camera in....having them just send it back for me to try doesnt sound like a good idea now either....

waiting and hoping

I forgot to read your last part, that you already sent it in for service. People with Magic Lantern have downgraded their 5DIII via Eos Utility when the normal way didn´t work out. Anyway, hope the service centre fix your camera.

Thanks Peter,

if you're refering to the 'Magic Lantern Guides" for various cameras, i have searched but been told no one has published one for the 1Dx due to the limited number of them in use, and lack of profit to put time into one for this series camera, a bit disapointing .......

There is nothing for 1DX, but 5DIII is also locked out the normal firmware downgrade way. Because everyone at ML wants to downgrade to the right firmware they found out that it still works to downgrade via Eos Utility. The same thing should work with an 1DX.

Thanks Peter,

hoping to hear something from Factory Center today.

i liked the added information in the Magic Lantern Guides, wish they made them for all our cameras.


Its not dirty lens contacts.  You got a corrupted firmware install. Canon will fix it and is the only way I know of that can.

Anyway hoping it is not a hardware malfunction but in either case Canon will fix it.  It still has warranty?  If you try any ML Smiley Sad stuff, you won't have any warranty.  Avoid it while under warranty!

EOS 1DX and 1D Mk IV and less lenses then before!

took delivery of the new 1Dx July 2013;

now <=14000 shutter events, i'm also relatively sure the firmware is the issue, hoping they will take this into consideration considering this is one of their flagship cameras and goodwill this.

have not tried anything that factory service rep hasn't asked me to try,

waiting on news from Factory, nothing yet, they received camera Monday morning per UPS, so i hope i will hear something today,

thanks for reply

correction, UPS stated they delivered camera to Newport News Factory Center , Tuesday morning not Monday.

wanted to correct that,

have not heard back from Factory yet

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th