Showing results for 
Show  only  | Search instead for 
Did you mean: 

T6i + Canon Connect + Samsung Fold connecting issue to App


Hello All,


I currently have a T6i Rebel and have been having issues getting it to stay connected to the Canon App to transfer pictures to my Samsung Fold Phone.  I've been having consistant problems and fight everytime to transfer even 1 pictures or more. It will connect but will be slow to load previews or even stay connected.  If i do select my pictures on the phone and hit transfer it will start and it may transfer 1 or could transfer 10 and then start to hang up and then disconnect.  I do run Bitdefender on my phone and thought it might be that interferring with the transfer but i made sure that it wasn't turned on and it still has the same issues.  When the disconnect happens sometimes on the phone it will say there is no photos on card or target not found and then will attempt the reconnection and will connect to the phone again.  Before this phone I had a Samsung Note 9+ and didn't have any issues like i'm having now.  So far I've reset the wirless settings on my phone, i do multiple restarts or shutdowns on the phone, I have the latest firmware for the T6i installed.  Has anyone else ran into this problem before?  Is it a phone compatibility issue potentially?  I've also tried searching youtube as well and didn't find anything to really help.  Any other things to check?




Product Expert
Product Expert

Hi SD40-2emdCR,


Thanks for checking in with us!


I suggest that you delete Camera Connect from your phone and then download it again from the app store. Sometimes that can resolve quirks that come up from merely updating the app.


Beyond that, on certain Samsung devices, we have run into issues with one of the default settings.


In your settings under the Wi-Fi settings, look for the ADVANCED option. Once there, you should see the AUTO NETWORK SWITCH. This is designed to allow the phone to roam seamlessly from available Wi-Fi networks to cellular data, but it does interfere with our Wi-Fi devices. Try disabling this option, and see if that makes a difference.

Hello Nick,


Sorry for the delayed response on this issue.  I wanted to give it a few months to see how things went.


I initially reinstalled the APP on the phone and went through reconnecting it and for the first few days this worked but by the end of the first week it would not let me connect again at all and I even uninstalled again and went back through the setup up process and it would just randomly disconnect on me either trying to connect or in the middle of importing photos to the phone.


What I ended up doing and it works everytime now but is a small hassle is this:


1.  Connect to your wirless system on your phone.

2.  turn on the camera and go to Menu and then Wi-Fi function.

3.  Connect to smart phone.

4.  Review/Change settings

5.  Change Set.

6.  Camera access point mode, hit ok.

7.  Easy Connection, hit ok.

8.  Start the Camera Connect on the Phone.

9.  Press Easy Connection Guide.

10.  Select whatever your camera is call.  Example Canon EOS Rebel T6i, click the arrow.

11.  Hit next, Hit next, Hit next, until you see Display smartphone, wi-fi settings and click that box.

12.  Wait for your wirless to appear on your phone and select whatever your camera is called, example:   _Canon0A.

13.  Wait for the Password to pop up on your phone and enter the password from the camera. (8 digit password)

14.  Click connect and go back to the App on your phone.

15.  Click ok on your camera and go to your phone and click start.


It will now be connected.  This way has worked everytime without disconnecting in the middle of an import.  It's a bit of a hassle but this has been the best option so far.


I appreciate your time and if there is something additional that can be added or help, please let me know.


Take care,



03/28/2023: New firmware version is available for EOS-R5 C
03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.