cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

T5i Menu Problem

Nickflightx
Apprentice

My T5i has developed a problem. When I turn the camera on, the camera does is sensor cleaning thing and that shows up on the screen. Then when that finishes, the menu with all the setting info thats supposed to come up does not appear. Live view still work and I can change settings from there. I can also hit the menu button and go through that no problem. Ive tried everything from hitting the info button to change screens (it has two black screens and on visible screen that has freespace, color space, etc.), ive taken the battery out, removed lense, memory card and that hasnt fixed it. Ive cleared all camera settings and custom functions, none of those have helped. Also the image review doesnt show up after i take a shot. Ive confirmed its on and even changed the duration and hasnt helped. I am on firmware 1.1.4 for cam and 1.5.0 for lense. This started out of the blue, it worked perfectly fine in the morning and then started doing that.

6 REPLIES 6

jrhoffman75
Legend
Legend

This info I have read; no first hand knowledge. Remove battery, switch camera on and let sit for a few days. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

ebiggs1
Legend
Legend

John is correct.  Removing the battery does not reset a T5i.  This is because it has a recharging system in it and it must be depleted.  This will take several days or longer.  Some cameras have two batteries.  One for main power and another smaller one for keep alive systems.  That kind can be reset by removing the batteriesbut not your T5i.

 

Clear al settings, should work, however.  Did yuo happen to press the Disp. button by mistake?  That turns off the LCD screnn menus.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

There is no Disp button on the T5i

It's the INFO button on T5i. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I have pressed that. There should be 3 different screens, the black one, the main setting page, and a general info page. When I press the button 3 times, this is what comes up, 2 black screens, and the general info page.

Call Canon service. Smiley Sad

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the press release
Announcements