Showing results for 
Show  only  | Search instead for 
Did you mean: 

Sudden onset of extremely dark pics and no flash...


Hello.  I am new to the forum.  Please forgive me if this was already addressed elsewhere.


I have a Cannon EOS Rebel T3.  On the bottom of the camera is shows: "Cannon DS126291"


I have had the camera for several years and it has functioned wonderfully. I almost always use the "Full Auto" mode.  The last two days I was on a Yardsale trip and in the middle of the trip, I noticed that the camera doesn't seem to be recognizing the light/dark situations and doesn't activate the flash.  In situations where the scene is light enough to take a decent photo, and normally would not need a flash, the picture turns out completely dark.  In scenes that would normally need a flash, it doesn't pop up.  


Photos in bright sunlight come out, but are a bit dark.  Photos in cloudy situations are visible but quite dark.  


One funny thing.  I have always used the smaller "tradtional" optical viewfinder mode and was using it as always the last two days.  I find now that if I switch the camera over to the mode where the LCD screen now becomes your "viewfinder" the camera will take a picture that comes out OK and the flash even pops up.  I then tried to switch back over the using the smaller optical viewfinder (leaving the flash up) to see if it would work, and again, no flash and a completely black picture.  


I tried resetting the camera to factory settings in the menu going to "P" mode on the camera dial, going to the second "wrench" screen and going through the clear all settings procedure.  Nothing changes.  Same problems.  


It WAS raining on the day this started but not heavily at all.  I have gotten the camera much wetter in years past and never had any issues and don't think this is the problem here.  Just wanted to mention it.


Can you help?


Thanks so much!


Decent light.  Full auto mode.  Viewfinder. (again, had to resize.  Hope that doesn't mess up the settings)


IMG_6345 (Medium).JPG



Inside, raining outside.  Full auto mode and traditional viewfinder.  Flash did not pop up.  (again it NEVER pops up at all now when using the traditional viewfinder)



Close up inside my car full auto mode with viewfinder



Same shot a couple seconds later, same conditions, full auto mode, Live mode LCD screen.  



I hope those include the EXIF data you need. I'm not sure exactly how to include that if not.

Something is definitely hokey with the normal autoexposure sensor. EXIF reports ISO 100, 1/500 sec , f16 or f/14. Normal daylight at noon would be ISO 100, 1/100 or 1/125 sec , f/16. Sunny 16 Rule.

The two "lamp" photos report unknown exposure program ; the others all report Normal.

I think there is water damage and given the age of camera repair might be cost-prohibitive.

Try taking battery out of camera and let it sit overnight. It's grasping, but maybe it will reset things.
Maybe Tim will have a better suggestion.
John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

I understand.  Thanks so much for your time sir.

The EXIF data is indeed present in your image.  


On the images that didn't use flash, the EXIF data reports


Here's the EXIF for your "indoor" image where the falsh didn't fire:


Camera: Canon EOS REBEL T3
Lens: Canon EF-S 18-55mm f/3.5-5.6 IS II Shot at 24 mm
Exposure: Auto exposure, Program AE, 1/512 sec, f/16, ISO 100
Flash: Off, Did not fire
Date: August 6, 2015 3:57:57PM 
Color Space: sRGB
Field Of View: 51.0 deg
File: 4,272 × 2,848 JPEG (12.2 megapixels) 1,525,527 bytes (1.5 megabytes)
Notice it says the flash did not fire because it is "off" (this is a setting you can control.  In full auto (green box with "A+") the camera controls the flash and it will pop-up by itself if needed.  But in "Program" mode, YOU control if you want the flash on or off.  You can pop it up and tell the camera to use it.  
Later, you took an image inside your car (via live-view) and here's your EXIF data:
Camera: Canon EOS REBEL T3
Lens: Canon EF-S 18-55mm f/3.5-5.6 IS II Shot at 40 mm 
Exposure: Auto exposure, Program AE, 1/64 sec, f/5, ISO 800
Flash: On, Fired
Date: August 7, 2015 1:37:01PM 
Color Space: sRGB
Field Of View: 31.9 deg
File: 4,272 × 2,848 JPEG (12.2 megapixels) 3,227,133 bytes (3.1 megabytes)
Notice here that the flash fired because it was switched on. 
Make sure you familiarize yourself with how to force the flash to fire when you want it -- or prevent it from firing when you don't.  This is something you can control.
I'm looking at some of these other under-exposed shots, they are a bit of a mystery.   The "chopper" bicycle is underexposed by exactly one full stop... but that was taken in full "auto" mode (not "program" mode) and in "auto" mode it's not possible to dial in exposure compensation (it is possible in "program" mode.)  This image has no exposure compensation (it's set to 0) and yet it's too dark.  There's nothing in this scene that would have tricked the camera (e.g. an abundance of "white" can do that.)
Also, earlier you have the image of the woman holding the lamp (which is even more underexposed) and that has the shooting mode listing as "Flash off (Never fires)".  That's the mode next to A+ on the mode dial (the icon has a lightning bolt with a slash through it.)  Having it in that mode explains why the flash did not fire, but it does not explain why the camera mis-metered the shot.  At ISO 100 the camera should have used f/11 and 1/200th or f/16 and 1/100th.  This image is underexposed by approximately 2 full stops.
I noticed lots of different modes for these shots... full auto (a+), no-flash auto, and program ae.  Are you changing the modes deliberately, do you think you may be accidentally bumping and turning the mode dial, or is the camera flaking out on the modes (e.g. you set the dial to one mode, but get a different mode.)??
Tim Campbell
5D III, 5D IV, 60Da

No, I almost never adjust that dial. It is always on Full Auto (green rectangle) mode. I use that so I don't have to play with settings (since I am a truly amateur photographer and don't know the proper settings). That's why I have always liked this camera. Full Auto mode has always taken great pictures WITHOUT me having to do anything. I will (occasionally) use the no flash mode if the camera flashes in full auto and the shot looks too washed out with the flash but other than that, I really don't change anything and all of these shots (the dark ones) were taken in full auto.

So the ones taken in Live View (LCD screen as viewfinder) are all OK, it seems that the problem only exists when I try to use the traditional viewfinder?

I just tried taking a shot inside that normally would need a flash. I used the P mode and set it to activate the flash. The shot looks like all my other ones. Dark and the flash STILL does not fire. ??
click here to view the gallery