cancel
Showing results for 
Search instead for 
Did you mean: 

SL-2 MP-4 video clips will not play

ndralle
Occasional Contributor

I have the SL-2. It takes video clips in MP4 format.  I have several videos saved that were given to me in MP4 format and my desktop computer plays them just fine. I tried to play the new video from the SL-2 and it gives me an error “Windows Media Player encountered a problem while playing the file.”

 

 I opened up Windows Media Player and selected “help” then “check for updates”.

This gives me an error “An unexpected error has occurred. Setup was not able to detect any Windows Media updates.  Please try again later.”

 

My desk top computer is running Windows 7 and Media player 12 point something. The MP4 clips, from my SL-2, will play just fine on my laptop running Windows 10 with the Media player 12 but with a later version of media 12.  I suspect that Microsoft is trying to get me to upgrade to Windows 10.  The main reason I am dragging my feet is that the picture downloader in 10 is not as easy to use as in 7.  I know I will be forced to go to 10 but I did not want to upgrade any sooner that I absolutely had to.

 

After loading a number of video players, Cyberlink, VLC, Realplayer, Quicktime, and Mediaplayer classic, none of which would work, I discovered this.

The Canon owner’s manual in the fine print says this; "If you play back a movie with other devices, image or sound quality may deteriorate or playback may not be possible (even if the device support MOV/MP4 format)." (page 278 bottom)

 

So I called Canon tech services which are a bunch of sharp people and they were unaware of that being in the owner’s manual. Of course they had no solution either.   Any suggestions?

 

1 ACCEPTED SOLUTION

ndralle
Occasional Contributor

Well the whole problem with the download / play MP4 clips issue of my camera was related to my downloading the wrong program off the web.  Always download the latest version off the web I said to myself! Great but you must load the correct one!

 

The reason my laptop worked so well is that Microsoft made win 10 much more

sophisticated and it knew what needed to be done and did it. Not so with win 7.

 

Thank you for help!  Also thank you Canon customer support!

 

 

View solution in original post

8 REPLIES 8

diverhank
Respected Contributor

What you need to be able to play a certain video files is to have the correct codec for it.  The SL2 mp4, if I'm not mistaken, uses the H.264 codec, while not new, is still fairly new and not native to Windows 7.

 

You need to search for the H.264 codec on the internet (try www.divx.com), download  and install it on the computer and then you can play the video on most players (don't count on Windows Media Player, though).

 

If you haven't installed the software that came with the SL2, you should.  While I'm not sure, usually the software would load all necessary files including codecs so that you can play the files.  Try this first then try downloading the codec - you run the risk of downloading something malevolent.

================================================
Diverhank's photos on Flickr

ndralle
Occasional Contributor

Thank you for your help.  I have a number of computer wiz's at my disposal and they have suggested the same thing and even provide links to said downloads none of which work. The fact that Canon warns you on page 278 of the owners manual is a big red flag that for some reason .MOV / MP-4 fiels may not work !

 

Disappointed in Canon!

 

Neal 

diverhank
Respected Contributor

Nah I don't buy that at all.  The blurp in the manual only applies if you put the mp4 back to the SD card and try to play it on the camera.  You can't do that with jpegs (and possibly RAW) either.

 

This has nothing to do with your not being able to play it on your computer.  You have to have the right codec to play. It's that simple... I haven't heard anybody else complained about not being able to play theirs on the computer so it must be unique to your computer.

================================================
Diverhank's photos on Flickr

ndralle
Occasional Contributor

Well thank you again.

 

I have had a number of my computer wizs send me codec.  I you have a web site to send to me I would be glad to give it a try.  Nothing to lose on my end.

 

 

ndralle
Occasional Contributor

Well the whole problem with the download / play MP4 clips issue of my camera was related to my downloading the wrong program off the web.  Always download the latest version off the web I said to myself! Great but you must load the correct one!

 

The reason my laptop worked so well is that Microsoft made win 10 much more

sophisticated and it knew what needed to be done and did it. Not so with win 7.

 

Thank you for help!  Also thank you Canon customer support!

 

 

I can not play the video clips on windows 7 or windows 10. Spoke to Canon over the phone as well 2x, they were unable to help. I am going to return the camera and buy a nikon. this is pathetic! I have owned dozens of cameras over the past 30 years for weddings and home use, and they are all plug and play. this is so irritating it just drives me nuts and gives me the heebie jeebies just thinking about another canon. Kim Herrick

ndralle
Occasional Contributor

Hi Kim!

 

Sorry to hear you are having a problem with your SL-2.  Just above your posting was my own reply to my problem I was having. I had loaded the wrong software for my computer.  Canon technical assistance helped me greatly.

Call  them again at 1-800-652-2666.  Sometimes just getting another person to help you will fix your problem.

I have had nothing but great luck with my Canon cameras!  

 

Sincerely

 

N Dralle

thanks, after more communication with canon, they called back 2x, we had no luck. HOWEVER - i found that if the files were downloaded automatically to my win 7 pc they would not play. I then manually copy and pasted them from the camera to the pc and they would play. something must be wrong with their auto downloading software.

 

Kim Herrick