Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel T6s focus will beep but will not take photo


I have a Rebel T6s, In Autofocus when I point the camera at the subject and press the shutter button I hear the beeps but the camera will not take a picture.


I took the camera in to have it serviced and of course it would not do this again.  I thought great, cheap fix.


I have tried in low light, average daily light and outside in the sun. It happens in each condition and I am missing some great photos.  Can anyone offer help?


I have tried different lenses but it still happens.


Thank you



Helo ChrisSS, 


In order for the community to assist you, we recommend supplying additional information.  Does it seem to matter which lens you use on the camera when this issue happens?  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


" It happens in each condition..."


Do this, on a nice day put the lens in AF with the switch on the lens. In the menus go to the Tools tab and select Clear all settings, it may be worded a bit differently.  A fully charged battery and a known good SD card. Put the Rebel in Auto mode the green square. Find something with nice contrast outside and take a shot or several.  If it works it is OK if it doesn't it needs service.   Call Canon 1 (800) 652-2666


If it works outside on that nice day but doesn't at other times there is a problem with how you do use it, the settings or conditions.

EOS 1DX and 1D Mk IV and less lenses then before!