cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

R100 won't record video with Rokinon EF mount cine lens attached to an adapter

markbolden
Apprentice

Am I missing something? On my T6i I had no problem recording video with my Rokinon cine lenses. I upgraded to the R100 and have a [pro]master EF-RF mount which works great with my Canon EF mount AF lenses (video and still shots). When I connect my Rokinon manual focus cine lenses and try to record video or even take a photo my camera does nothing. No shutter whatsoever.

Is there a menu setting I need to set for this to work?

Thanks in advance!

5 REPLIES 5

rs-eos
Elite
Elite

Note that if you're not using one of Canon's EF-to-RF adapter and using a third-party lens on top of that, it may very well lead to incompatibility issues.

If you get the chance, try a Canon adapter to see if there'd be any improvements.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Agreed, but I did see a thread a day or so ago where the solution in the discussion was to enable shutter release w/o lens. I see YT tutorials on how to do this on other models, but I am having trouble finding this option on the R100. Any ideas on where I can find this in the R100 menu?

Yep, definitely a feature of EOS R100.  See page 593 of the User Manual.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Thanks! I will give it a shot. Also, I just ordered the actual CANON adapter for future use. Cheers!

Waddizzle
Legend
Legend

The mount adapter is an issue unto itself. 


Are able to capture stills?  When using a fully manual lens you must go into the menu and enable “release shutter without lens”.

--------------------------------------------------------
"The right mouse button is your friend."
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements