cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Quiet, high pitched squeaking sound when powering off 60D?

Hollydesautels
Apprentice
I just got a 60D body yesterday, and I just noticed a high pitched, very quiet noise that happens for a second or two when powering the 60D off. My Rebel t3 does not make this noise so I was wondering if it's normal?
3 REPLIES 3

TCampbell
Elite
That's the noise of the piezoelectric cleaning system. It vibrates the low pass filter (located just in front of the sensor) to shake dust loose.

In some cameras it sounds like a couple of squeaks. My 60Da makes the same noise. No reason for concern. Some cameras start out not squeaking when new and end up making the squeak later.

The good news is I have never heard of it actually being a problem.
Tim Campbell
5D III, 5D IV, 60Da


@TCampbell wrote:
That's the noise of the piezoelectric cleaning system. It vibrates the low pass filter (located just in front of the sensor) to shake dust loose.

In some cameras it sounds like a couple of squeaks. My 60Da makes the same noise. No reason for concern. Some cameras start out not squeaking when new and end up making the squeak later.

The good news is I have never heard of it actually being a problem.

No, the good news is that the OP is still young enough to be able to hear a squealing sound at such a high frequency!

Bob
Philadelphia, Pennsylvania USA

Hollydesautels
Apprentice
Awesome, thank you that's very good to hear. And Robert your reply is great haha!
Announcements