cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems with the flash T6i

mkbeanie21
Apprentice

I am a new user and have only had my EOS Rebel t6i, about 3 months. All of a sudden the flash isn't working properly. Photos are coming out darker with flash than without. As i'm still new I typically only shoot in no flash or creative auto mode. I havent made any custom setting and recently did a camera reset. I never adjust any balances or any features. Please help!

3 REPLIES 3

Tim
Authority

Hello mkbeanie21, 

There are a few troubleshooting steps I'd like to help resolve this issue. We'll reset the camera, which should restore it to a default state. These steps should clear out the memory and thereby any errors which may be present.

- Anything attached or installed in the camera — memory cards, the lens, the battery, battery grips should all be removed.

- Once the lens is off let's check it using the steps below.

a) Clean the lens contacts* to restore connection with the body.

*Warning - Do not clean lens contacts on either a Canon lens or the camera body with an eraser! It's easy to rub off the gold plating on these contacts and end up with data communication problems! Our strong recommendation is to use a soft, clean, micro fiber cloth. Please do not use anything abrasive.

b) Try using a different Canon EF series lens. It doesn't have to be the same focal length as the one you were using.

c) If you are using a third party lens, we recommend discontinuing its use. There can sometimes be communication error related issues with third-party lenses. Ensuring that you're using a Canon lens eliminates that as a potential factor in the error.


If the issues seem to persist the next step would be to send the equipment to Canon for service.

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

ebiggs1
Legend
Legend

" I havent made any custom setting ..."

 

On purpose, but maybe inadvertently you did!  Reset the Rebel to factory default. In the Menus under Tools clear all settings. See your manual for complete details on how to do it.

 

EB
EOS 1DX and 1D Mk IV and less lenses then before!

ebiggs1
Legend
Legend

"a) Clean the lens contacts* to restore connection with the body."

 

I disagree with Tim on this one.

I generally refrain from suggesting people do this.  You can do a lot of unrepairable damage if you are not careful. And, I have not seen it help very often or at all. The motion of mounting and removing the lens is generally enough to keep the contacts clean enough. I know as soon as I write this somebody is going to chime in and say cleaning the contacts fixed their camera. So, if it makes you feel like you are doing something, go ahead.  Just be careful.

 

" Photos are coming out darker with flash than without."

 

It is possible for the flash tube to burn out.  Call Canon if the reset, or contact cleaning Smiley Frustrated, didn't work.  1 (800) 652-2666

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the press release
Announcements