Showing results for 
Show  only  | Search instead for 
Did you mean: 

New photos disappeared. Canon 60D


Hi first post here. I've been out tonight capturing a fantastic aurora display with my Canon 60D. Took many photos, we looked through them a few times on the camera display all looked good. I've took the SD card out and into the SD card reader and gone to open them on the computer and they're nowhere to be seen. Put the SD card back in the camera and they've disappeared and the latest image was from a previous outing a couple months back. What happened? I guess they're gone forever and no way to get back?  



Possible card corruption?  What specific card are you using? Is it a full-sized card or one that requires an adapter? Those that require adapters can be very problematic.

If you have a SanDisk card, there is data recovery software available, so you could try that.  Other brands may have their own recovery software as well.

One thing to do though is to flip the write-protect tab on the SD card before doing any additional work.  Just to ensure that nothing is going to do additional damage to its file system.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers


Like you, this just happened to me 2 days ago after taking many Iceland photos including a lot of great Northern lights shots.  I am shooting with an R5 with a delin 1TB CFExpress card and a Sandisk Extreme Pro 128 GB SD card.  I viewed the photos on my camera.  When I tried to download the pictures from the SD card via a sandisk card reader onto my Macbook Air (M2 2022), only photos from 11/2022 and before were there.  I had previsously successfully downloaded more recent photos (not including the newest set) from this card but those pictures did not appear.  I then tried downloading photos from the Delkin CFEXpress card using a Delkin CF card reaer and the macbook would not even recognize the card.  When I put the card back into my camera, all most new photos and some of my old ones were gone.  I had previously used both cards and card readers without problems as cenetly as 2 months ago (i only take a lot of photos on vacation).  I had updated my mac OS to Monterey and there have been 1 or 2 updates as well.

I immediately removed both cards from my camera.

Can any one offer any suggestions?  I don't think both my cards could go bad at the same time.




Are you sure that the photos haven't been placed into a different folder on the card?

Steve Thomas


See his other post.  He found the images on his CFExpressB card.

EOS R5 Photos disappeared from CFExpress and SD ca... - Canon Community

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Update: I updated my R5 firmware, and eos utility firmware and I can now see the photos when I use the card reader.  However, I cannot move the files as a group, only one individual file at a time!  This is obviously a problem as I would like to quickly download the images to my external drive.


National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th