Showing results for 
Show  only  | Search instead for 
Did you mean: 

My 60D thinks it has an external flash attached all the time. Cannot get it to reset. Anyone fix?


My 60 D thinks it has an external flash attached all the time. Anyone else have this problem and is there a solution other than sending it back for repairs?



You'll most likely need to send it in but here's the link to an older article that might help you trouble shoot it.


"A skill is developed through constant practice with a passion to improve, not bought."


If you have mounted an external flash on the hot shoe recently, it is possible that the microswitch is stuck in the depressed position.  If you look carefully at the hotshoe there is a thin metal strip on  the side nearer to the shutter button. Underneath it is a tiny black mocroswitch.  The thin metal strip acts as a spring...when the flash is mounted, the strip depresses the switch telling the camera there's an external flash. When you remove the flash, the strip springs up away from the switch, undepresses it.  Well the metal strip is a poor spring, it doesn't always pop back up.


Try running a thin piece of paper between the strip and the switch, or gently try to bend the strip back away from the switch.  It might be as simple as that.  Try that before you send it back in.



Want to thank me? Give me a makes me happy.

Diverhank's photos on Flickr




If the microswitch on the hotshoe is raised and you still receive the same message, your EOS 60D will need to be repaired by our Factory Service Center. To start the repair process, you'll need to complete a Repair Request on our website.


If the camera is more than a year old, you may also participate in the Canon Loyalty Program instead.  The Canon Loyalty Program option allows you to replace your current camera for a discounted fee, plus shipping.  The original non-functioning camera would then be returned to Canon USA for recycling using a prepaid shipping label that would be provided.  

If you would like to take part in this option, please call our Sales Department at (800) OK CANON (800-652-2666) seven days a week, 8am to Midnight.  Let them know you have been working with online support and the Canon Loyalty Program was offered.  Be sure to have your serial number for your camera at the time of your call.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


This is a fairly common and pretty easily solved problem. Seems to happen more on some models than others, but I've seen it happen on various Canon models over the years. It really is a minor issue, once you know what's happening, and is very easy to fix yourself.


The link above is showing other flash/hotshoe related repairs and a lot more disassembly than you need to do, to resolve this particular problem.


Go to this link that's more specific to this problem...


This website has a couple good illustrations and suggests bending the spring with a small, flat screwdriver. That will work, but I find a wooden or plastic toothpick works well, too. Just insert the the screwdriver or toothpick into the slot at the larger end, they slide it along the slot toward the narrowest end to gently bend the spring back up a little, and the microswitch should pop right back up. Don't do too much. It usually only takes a slight bending of the spring. Problem solved, though you might occasionally need to repeat the process.


Alan Myers

San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7D(x2), 50D(x3), some other cameras, various lenses & accessories




Thanks everyone. The fix worked.