cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Flash not firing on eos rebel t6i

Hut_fig17
Apprentice

So i just bought the camera off marketplace a few months ago and everything was working fine.

Just a few days ago i went to take some pictures so i popped the flash up  and went to shoot but the flash wasn't firing.

It sounds like it tries to fire but the light doesn't actually turn on.

Occasionally when trying to focus the flash will turn on for a split second  just once and then it will continue not working.

I tried recharging the battery and doing a factory reset but still nothing 

It doesn't matter what mode im on the flash won't fire. I checked to see if dirt or anything got into the small button but there is none and the button is up fine.

I have no idea what to do... Any suggestions??

2 REPLIES 2

Waddizzle
Legend
Legend

Switch the camera to the Green [A+] shooting mode and test the flash indoors with normal lighting.   In most circumstances, average room lighting should cause the camera to enable the onboard flash and use it.

However, be aware that the onboard flash is not very powerful.  Strobes can draw a lot of current and quickly run down a fully charged battery.  If the flash were working properly, then you will notice that it projects a pretty harsh light and is not very effective beyond 2-3 meters, or 7-10 feet.

--------------------------------------------------------
"The right mouse button is your friend."

ebiggs1
Legend
Legend

"I tried ... doing a factory reset but still nothing"

 

Are you sure? There are two controls you need to reset. Menus, Tools, Clear all settings and Clear all Custom settings. If the flash is popping up then the camera thinks it needs it. Flash tubes do burn out.

 

"Switch the camera to the Green [A+] shooting mode and test the flash indoors with ... ."

 

I would try that but I would add do it in a darkened room. Make sure the camera thinks it needs the flash. But first make sure you do the complete reset. Other than that there isn't much you can do.

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Announcements