Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel T7 Won't Take Pictures with AF


My camera is not working anymore in the AF mode!! I have to switch to the MF mood to take a picture.


I have Canon EOS Rebel T7. I can’t take pictures on AF, even though it’s flashing, but it’s giving me “busy.” I have tried to clean and reset it, but it’s still the same problem. I don’t know how to work in MF; every time I take pictures, it’s burly and not good as the Af:( any help?



What is flashing?  The red LED on the rear for the SD card?  Flashing icons in the OVF, optical viewfinder, is how the camera calls for help.

What brand and storage capacity memory card are you using?  Recommend only using full size memory cards purchased from major name brands, 32GB or smaller.  Be sure to format the cards in the camera prior to first use.

The AF system in the camera requires a minimum amount of light to “see” the subject.  A dimly lit room is usually insufficient light for the AF system to operate properly, so it disables itself.  A lens has a minimum focusing distance, or MFD.  It is unable to autofocus on objects that are too close. Different lenses have a different MFD specification.

Try testing the camera outdoors on a bright sunny day.  Focus on something 10 to 20 feet away.

"The right mouse button is your friend."


Can you better describe what is actually happening? What is flashing? Where does it say "busy"? Do you hear any sound from the lens when pressing the shutter button halfway looking at different-distance subjects?

There is a flashing light on back of camera when the memory card is being written-to. There is a flashing indicator in the viewfinder if the camera cannot focus.  

You do manual focus by switching the lens to MF and turn the focus ring. Can you see the image in the viewfinder change when you do this?

There are so many possibilities here that you HAVE to give better information.


I'm only guessing - but this camera uses the older 18-55mm IS II lens, so if it's flashing "BUSY," and not allowing you to take a picture in AF, but it is letting you take a picture in MF mode, that means the camera can't lock focus. Do you have any other lenses to try? If so does it work fine on them? 

When you try to take a photo in AF, do you hear it trying to focus and making some zippy noises? Maybe some clicky noises, but it just won't take the photo? If so... I'm going to take you way back to when I was in phone support 10 years ago...
Try this:

  1. Put the lens in MF mode. 
  2. Take the lens off of your camera.
  3. Twist the FOCUS ring (the tip of the lens) all the way to one side (extend it). You may hear a click noise - maybe a tiny bit of grinding or slight crunching. This is good, but don't FORCE the lens.
  4. Twist the FOCUS ring all the way to the opposite side (retract it). Again, you may hear a couple of clicking noises. What we hope is happening is the focusing motor being put back into its proper place.
  5. Put the lens back on the camera.
  6. Put the lens in AF mode.
  7. Turn the camera on.
  8. Put the camera in AUTO or P mode.
  9. Take a test photo.

I'd say that resolved about 80%+ people I had do that on 18-55mm IS II kit lenses. If it doesn't, your lens is damaged and it's time to look at something else for your walk-around lens. 

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5