Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel T5i Format Not Supported with iMovie




I am new to the community and still a newbie with cameras and need some assistance. 

I have an EOS Rebel T5i.


I wanted to make a short video. It has been a few months since I recorded a video with my t5i. Today, after recording and going into edit my footage on iMovie, it says that the format is not supported. I noticed my video saved as a MOV instead of the usual MP4. 

I tried converting it to an MP4 and it was still not supported. (mp4, m4v, mpeg-4 are not supported)

I have tried putting the sd card into another camera where I can connect to the canon camera connect app, and the app is saying the same thing.


I'm not sure what happened to cause this change and would appreciate some help in fixing this for the future!



I can not reply to comments, without my comment being marked as spam. :L  [We think we've fixed that!]



I found the solution via "apple support communities". 





"OK, progress comes from poking about randomly, apparently.


It appears that if you create an empty project, the files in question suddenly appear to be usable, and iMovie happily lets you import media.


That question answered it seems."


It worked for me and I am just... at a loss for words.

View solution in original post



Didn't the T5i come with Canon Movie Software?  It should be available for free download from Canon.

"The right mouse button is your friend."


What version of iMovie do you have?

Can Quicktime play it?

Did you try to film another movie to see if it worked?

It looks like a corrupt file.

Hello kvbarkley,


I have version 10.1.12 for iMovie on my 2011 MacBook pro:


mac OS High Sierra Version 10.12.6

Processor 2.3 GHz Intel Core i5

10 GB 1333 MHz DDR3

Intel HD Graphics 3000 512 MB


I have Quicktime Version 10.4 (928.13). It does not allow me to export into another format. 


I tried changing my camera setting, updated the firmware, I recorded several more times throughout the day, and changed SD cards, yet when I look at the information it still says the format is MOV and I can not edit it on my mac or on my brothers HP through movie maker. :c

Can it *play* in Quicktime.

More and more it sounds like a corrupt file.
Try to take another short movie, import it to the computer and see if it plays.

Hello kvbarkley,

I have Version 10.1.12 of iMovie.
2011 macbook pro:
2.4 GHz Intel Core i5
10 GB 1333 MHz DDR3
Intel HD Graphics 3000 512 MB

I have Quicktime Play Version 10.4 (928.13), yet it will not export the video to any other format.

I filmed several times during the day, tried different sd cards, updated the firmware, and tried to use window movie maker on my brother HP and it is still being saved as an unusual MOV.

Yes, it is playable on Quicktime.

You might need to get handbrake to convert it.

Is there anything that can be done to get my camera to record videos like before, in mp4 format?

I never had to convert formats before. I just record video, insert the sd card into my mac sd slot and go straight to editing. This is so bizarre...

T5i's record in .mov:



Strangely enough, my T6S uses the same codec, but wraps it in an MP4. Go figure.