Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS RP Issue - Turns ON by itself.


When the power dial is set to "off" the camera powers "on" by itself and flickers "on" and "off" until the battery dies. I tried updating the firmware and removing all accessories, however the issue still persists. 


04/20/2021 UPDATE (for Canon techs): 

- The issue is present with / without the accessories (i.e. lens) attached.

- Tried removing the battery for a few days, and putting it back in. Issue still persists.

- If you insert the battery back in (with the SD card), it starts flickering again. Likewise, if you press the shutter button, it turns ON even though the dial is OFF. 

- I've tried hard resetting to factory defaults. Didn't solve the problem.

- Updated firmware, still not solved. 


* Will be sending it in for repair. Thank you to everyone who responded. 


Video #1:


Video #2:


Sorry, sounds lke it's time to send it back to Canon USA for an exorcism.

Hi I am having this same problem. How did you resolve the problem? Or what was the outcome?

Thanks for all the responses. I'll be sending it in for repair. Wasn't sure what to do initially.

Side Note for the CANON techs that view this thread for my repair:
- The issue doesn't present itself immediately. After inserting the battery back in, let it sit there anywhere from 15 - 30 minutes, and the camera start "flickering ON/OFF".
- Every time I think the camera is back to normal, after some time passes, it just start flickering again while the dial is in the OFF position.

By chance do you have Wi-Fi and Bluetooth enabled and have the camera "paired" with your computer? The pulsing of the red "busy" LED looks fairly regular, rather than random. Could your camera be trying to transfer files to the computer?

I don't think so. I never used the Wi-Fi / Bluetooth feature; so its definitely not transferring files because I never paired it.


I am not 100% certain yet, but I think this may be a symptom of the LP-E17 battery starting to die. I had exactly the problem descibed. I tried everything, changing firmware, changing lenses, reseting the camera (YUCK!) formatting and changing the SD card, nothing helped. I swaped to my second battery, and everythig was MUCH worse! I got a new battery today, charged it, and so far (about 1/2 hr) I have not had any sign of the camera switching on by itself! Now it could also be that there has not been a battery in the camera for 24 hrs too, and something got rest, but as of now, my RP is functioning as expected again. Hope this helps.

Well, the new battery solution didn't last. The camera still turns itself back on with the new battery, so this is not the problem.

@AndrewRJones wrote:

Well, the new battery solution didn't last. The camera still turns itself back on with the new battery, so this is not the problem.

Did you ever go into the Wireless menus and make sure that they were disabled?


When your camera turns itself ON, in what position is the power switch?  A camera is not OFF, until you switch it OFF.

"The right mouse button is your friend."

WiFi and Bluetooth are definitely both disabled, and the camera on/off switch is off. The camera will switch off as normal, including the sensor cleaning. Then it sometimes takes several minutes, but the camera then turns on with the switch still in the off position. After that the behavious is erratic. The only way to switch it off is to remove the battery.

Got the same problem, could you fix it? I would appreciate your comment. Thanks in advance!