Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R6 WiFi failure (2nd camera)


My new R6 will not detect or find my home WiFi (or any other wifi) network. It shows "Search fo access points" and "Searching..." and then nothing.


It *will* allow the phone to connect to it, if I use the "connect to smartphone" method (this is where the camera starts it's own wifi nertwork). But I cannot connet to my wifi to, e.g., transfer via ftp, as I did with my 5D4. I have tried with both 5GHz and 2.4GHz wifi networks.


This is the second camera with this symptom (the first one wouldn't even allow the local connection). Canon support told me to send the first one back. 


I have updated the firmware to 1.1.1. No difference.


Any ideas? Surely I can't be the only one. My phone can see multiple wifi networks.


I just got the R6 a couple weeks ago and have similar problems getting it to connect to wifi. I can eventually get it to work by trying a bunch of things, but I can't figure out a consistent order of steps. And it's unstable once I get it connected, usually disconnecting after even a short pause in activity on the camera, then I have to go through the whole process again. 

If you can't turn the wifi repeaters off what works for me is:


(This assumes you have connected before once e.g. by turning off the repeaters).


1. Find the spot in your house where, when you press the "connect" button it does not hang (out of range of all but one mesh device). For me this is halfway up my driveway. You can just hit the shutter button halfway to exit and try again if it hangs.


2. It then shows "connecting to XYZ" or whatever your WiFi is called.


3. Immediately sprint to a better location before the connection times out. I manage this about 50% of the time.


4. If successful it then says "connected to ftp" (or whatever). And you can then select and transfer pictures.


Good luck!







My new R5 has the same issue in certain locations. Stuck in the "Searching for access points" menu screen. It never finds a network. I'm trying to connect directly to my laptop, NOT find a acess point. 


Works when I get back home or leave the offending location. 

Was this issue solve?

On your phone or PC do you see any networks with non alphanumeric characters or names that are extremely long?

You could try constructing a very simple faraday cage. With the router in the same room leave one side open and operate the camera from within the cage. That should greatly reduce wifi interference and broadcast from other routers.

If that's not doable try bringing one of your mesh access points into a bathroom (all doors and windows closed) and try scanning again.

I have a mesh of 3 AP providing both 2.4 and 5ghz with WPA2 and seeing an issue connecting quite often. I have my camera setup to upload automatically to and have to power off/on a few times to get it going and connect to the AP. I get an error 64 when it doesn’t work. I have the R6 so it can only use 2.4ghz. I was going to place a call to Canon. Maybe the AP broadcast timing is too slow and needs to be faster, it’s almost like the camera doesn’t wait to connect and gives the err64 almost immediately.

I did more research on this issue, and it seems I may have found why in a mesh network it's causing issues.  The Canon camera looks at every AP as an SSID (it's looking at the BSSID MAC address) and when selecting the AP to connect, it will show the channel numbers.  It's important to select the AP with the proper channel number that correspond to the AP closer to the camera (you might need to login to your mesh AP GUI to find out what AP is on what channel or use a Wifi Explorer tool). 


Then click (switch network) when going into the wifi settings, and pick the proper mesh AP with the 2.4ghz channel, if you don't see the closer AP, click refresh until you see.  The camera will only connect back to that AP, it is not selecting the strongest signal AP based on a particular SSID name, it will lock down to a single AP that is part of the mesh of AP.  


I will call canon support to see if this could be enhanced, as the camera is not always in the same location in the house when uploading pictures and it would be nice if it could roam between AP or pick the strongest signal, but the firmware might not be that smart.   I hope this helps. 



The problem is that you can't see any channel numbers or SSIDs - it just says "searching for network..." forever.


The only reliable solution I am aware of is to unplug all the extenders so that there is only one AP in the mesh. And hope that your neighbour doesn't also have a mesh network.

In my case I do see all the AP that are part of my mesh network listed with different channel as choices (all APs are hardwired to a switch and broadcast on the same SSID, they are not repeaters).   The problem is that I get the error message "cannot connect to wireless LAN".  This could be the difference in my setup where I don't have repeaters.  


As a test, I tried to create a new SSID just for my camera and made it available only on a single AP that is the one I wanted to connect and enabled compatibility mode with older wifi releases (802.1b/g) and that allowed it to connect more reliably.  It doesn't make sense because the camera is 802.1n but that's the difference for me. Now it seems to connect reliably, but will do more testing.   Being able to create multiple SSID is not something that all wifi access point system allows, so it may not work on all models and brands. 



I have exactly the same issue; can connect to phone, but not to wifi, and after choosing to search for access point, it just sits there without anything seemingly happening.

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.