Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R5 Connectivity Issue


Hi guys,


My EOS R5 cannot connect to any device (Macbook, iPhone, iPad) to transfer images.

When it is connected to Macbook the EOS Utility 3 does not recognize it. Even sometimes EOS Utility 3 recognized it the error occurs during starting transferring images.

When it is connected to the iPhone or iPad through Canon's Camera Connect app a similar error would occur during starting transfer images from R5 to the mobile device and the connection would be lost.


All the applications from Mac or iOS devices are updated to the latest version. My R5 worked yesterday. I have no clue what has been changed.

Now I cannot transfer any image from R5 to other devices using any application made by Canon. All the methods told by Canon's website have been applied in attempts of solving the issue. I can connect the R5 to my iPad Pro and import the images in the Photo app, which works perfectly.


Is there anyone having a similar issue?


Updates on 09-26 2020:


After quite a while since the post was created on 08-13 the issue persists. Bluetooth connectivity never worked. WIFI connectivity can be successful but unstable. The "target not found" error frequently happens in R5 when EOS utility is being used to transfer images and videos via WIFI connectivity between R5 and Macbook pro (Catalina 10.15.6). After not using the wireless connectivity feature for weeks it might work once with no issue when I tried. Once it worked with no issue for once it becomes unstable and unusable with errors.

The worst part of this issue is that Canon may not be able to reproduce the same issue on their end. Moreover, it is not persistent. I can only hope that Canon will eventually find out the defect they introduce in the software or hardware and fix it in the later framework update.


Upddates on 04-05 2021:


My issue was mainly the unusable conectivity with any type of connection between the EOS R5 and the computer/iPhone/iPad including USB-C cable, wifi and bluetooth.

The issue was significant while the USB-C cable was not working. I couldn't use any feature from the EOS utility like taking live shots from control of the computer or importing any photos/videos from the camera to computer/mobile devices. I had to use card readers to import my work every time. Later, I found that Imagin Capture or Google Photo app can actually detect the photos from the R5 via USB-C connection though Canon's EOS utility cannot detect the camera. The issue ws definitely only caused by the code in EOS Utility app of both Mac and iOS versions, not the USB-C connectivity.


The USB-C cable connectivity started working since the update of firmware 1.2.0. There was no clude how it was fixed for my camera as there is nothing mentioned in the update notes related to the connectivity issue. It magically started working with no issues in the use of all features of EOS utility.

Even nowadays I still haven't tried to use any wireless connectivity of R5. I don't have the confidence in the stability any more. Instead of wasting time to debug any protential issue I am just always using the USB-C cable for the connectivity.



I have the same problem too, even though my R5 was upgraded to 1.3.1 version this problem still exists. I think it should be related with home mesh wifi network, it can get wifi access points correctly in some university campus or homes with single wifi router.

I haven’t noticed a difference in batteries. I still get the issue no matter what battery.

1.4 is released for the R6?


since i changed to the canon battery i have had no problems connecting to my tablet, it  also worked,by mistake !!  for a short while on a non canon battery and then closed down!!. i put a canon battery in and instant connection!!!,,,,something fishy for sure.

Battery has NOTHING to do with the wi-fi and blue tooth connectivity.  I have had the camera for several month and Wi-Fi and Bluetooth never worked at my location.  They did work at the factory when I sent it in.  It has to do with MESH networks in that the connectivity in the camera in NOT ROBUST and can not deal with multiple networks with the same name.


Canon does not have the talent on board to understand and thus address the issue.  From what I have seen on this thread, it is clear to me that wi-fi and blue tooth connectivity will only work if you are in a REMOTE location or one that has NO MESH networks that are within range of the camera.

I'm not sure if it is specifc to "mesh" networks but more specifically EERO mesh networks.  Coud also be EERO in general without having them configured in a mesh system.  I switched to Cisco Meraki AP which are in a mesh configuration and it works fine.  The bigger problems is if your neighbors are using EERO then you're probably SOOL.

It could well be that there are multiple issues and that using the "H" battery does solve some of the problems. I have not had any connectivity issues connecting to my phone, Verizon hotspot, or iPad when using the LPE6NH battery. I have had problems with the camera stuck in "searching" mode and not connecting when using the older LPE6N batteries. 


It sounds like the mesh network problem could be a bug on top of the general connectivity issue that is experienced when using the older batteries. Does it make sense that the older batteries could cause the problem? It shouldn't. but unfortunately it does seem to have some effect on the ability to connect to a variety of devices/networks. 


I don't have a mesh network, so I have not experienced that specific issue, but me not experiencing that problem personally does not mean that it doesn't exist.


At the same time the fact that the "H" battery seems to solve the connectivity issues for a number of people that are not connecting to mesh networks means that it does seem to solve some problems. It might not solve yours, but it could be a solution to things other users are experiencing. 


Since this is a community, we all come from different backgrounds, different levels of technical expertise, and have different needs from our camera equipment, it's reasonable to post a solution that dramatically solved my problem to share with other users who are having a similar experience without having the expectation that it will universally solve all of everyone’s problems.

If it doesn't help you, you have my sympathies… I know how frustrating it is to have something not work the way it is advertised to work. But the fact that it didn’t help you doesn’t mean “Battery has NOTHING to do with the wi-fi and blue tooth connectivity.  “

That's great
click here to view the gallery