Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R5 Connectivity Issue


Hi guys,


My EOS R5 cannot connect to any device (Macbook, iPhone, iPad) to transfer images.

When it is connected to Macbook the EOS Utility 3 does not recognize it. Even sometimes EOS Utility 3 recognized it the error occurs during starting transferring images.

When it is connected to the iPhone or iPad through Canon's Camera Connect app a similar error would occur during starting transfer images from R5 to the mobile device and the connection would be lost.


All the applications from Mac or iOS devices are updated to the latest version. My R5 worked yesterday. I have no clue what has been changed.

Now I cannot transfer any image from R5 to other devices using any application made by Canon. All the methods told by Canon's website have been applied in attempts of solving the issue. I can connect the R5 to my iPad Pro and import the images in the Photo app, which works perfectly.


Is there anyone having a similar issue?


Updates on 09-26 2020:


After quite a while since the post was created on 08-13 the issue persists. Bluetooth connectivity never worked. WIFI connectivity can be successful but unstable. The "target not found" error frequently happens in R5 when EOS utility is being used to transfer images and videos via WIFI connectivity between R5 and Macbook pro (Catalina 10.15.6). After not using the wireless connectivity feature for weeks it might work once with no issue when I tried. Once it worked with no issue for once it becomes unstable and unusable with errors.

The worst part of this issue is that Canon may not be able to reproduce the same issue on their end. Moreover, it is not persistent. I can only hope that Canon will eventually find out the defect they introduce in the software or hardware and fix it in the later framework update.


Upddates on 04-05 2021:


My issue was mainly the unusable conectivity with any type of connection between the EOS R5 and the computer/iPhone/iPad including USB-C cable, wifi and bluetooth.

The issue was significant while the USB-C cable was not working. I couldn't use any feature from the EOS utility like taking live shots from control of the computer or importing any photos/videos from the camera to computer/mobile devices. I had to use card readers to import my work every time. Later, I found that Imagin Capture or Google Photo app can actually detect the photos from the R5 via USB-C connection though Canon's EOS utility cannot detect the camera. The issue ws definitely only caused by the code in EOS Utility app of both Mac and iOS versions, not the USB-C connectivity.


The USB-C cable connectivity started working since the update of firmware 1.2.0. There was no clude how it was fixed for my camera as there is nothing mentioned in the update notes related to the connectivity issue. It magically started working with no issues in the use of all features of EOS utility.

Even nowadays I still haven't tried to use any wireless connectivity of R5. I don't have the confidence in the stability any more. Instead of wasting time to debug any protential issue I am just always using the USB-C cable for the connectivity.


I know that.  I just wanted to see if anyone else was having the same issue.  I am in contact with email support right now but will wait till Tuesday to talk to Canon support directly.  Then I will have to send the camera back in.


Thanks for your input.  Also, maybe if others have the same issue it could be a kick in the backside for Canon to fix the problem

Have you gotten anywhere with this?  I'm having the same issue.  Cam is stuck at "Search for access point"

No I have not.  I did send the camera in.  The factoru was able to connect with both Wi-Fi and Bluetooth.  I got the camera back and the same problem persisted here. No connectivity with WiFi or Bluetooth.  


I was able to get bluetooth to connect with the iPhone ONCE.  I did te following

  1. removed the canon R5 from a the Iphone paired device list
  2. Uninstalled Cannon Connect on the iPhone
  3. re-installed Canon  Connect on the ipjhone
  4. reset the communication settins on the R5
  5. connected via bluetooth

That work ONE time then to reconnect I had to go thru the same steps AGAIN.  Not a useful solution.  At the same time I have NEVER been able to connect to my Windows Pro 64 desktiop witth Canon Utility


Canon DOES NOT have any clue as to what the issue is.  I have decided that I will just ignmore that feature and use the camera with a card reader of or USB thpe C cable they supplied.


The implementation approach they have for  bluetooth and Wi-Fi is to not depend on OS interface requirements, provide you user based documentaion, and just  wrote custom Firmware and Software code. In my mind that was not a good option. 

I swear Canon needs to get there ish together.  I called them today and they are saying the same.  Send my cam to them.  I use my camera professionally 2-3 times per week so not sending it in for now.  From what it looks it's just you and I with the problem?  And the'yre apparently not aware that it is a problem.  So how about just sending us out new cameras and if they work we'll send back the ones that don't.


I mean it's not a deal breaker because I don't really use it that much but I was looking forward to shooting without a tether cable.  

I had a technical session with a Canon support. He was super friendly and helpful. Unfortunately, the issue was not reproducible and it worked well with WIFI connectivity. Bluetooth connectivity never worked. However, it is not stable as it frequently fails to transfer images via WIFI.

Certainly, the wireless framework has issues. It is not reliable.

ok the issue started again. Mac does not read the camera properly when it is connected to the R5 via the OEM USB-C cable.

I had a shoot today at my studio and figured I'd test out the Wifi there and wireless showed up.  When I got home I tried it again and no Wifi.  Just sitting at searching for access points.  There is something strange going on.  Whatever it is it's probably the reason the your camera worke for Canon when you sent it to them.


Can any of you try taking there camera to another location and trying? 

I have tried everything including turning off my broadband router and eero mesh devices.  Also I am at 7,000 feet in an area that has MANY other networks that I can see with my phone, iPad, an iPhone.


I will try to go to a remote location where there are no other wi-fi networks to see if that my be the issue.

Hmmm...  Curious.  I have an EERO device.  I wonder if there is something that EERO could be doing.

My personal opinion is that troubleshooting is not our paid job. Even though your test turns positive it cannot solve the problem as it is not the case how we use our R5. As long as R5 is not working the way it is expected we can only add pressure on Canon to troubleshoot it for us and hopefully, they can reproduce the issue without having our own R5s sending to them.